DB Error: extension not found [Résolu/Fermé]

Signaler
-
 Bayaa -
Bonjour,

J'ai la solution à mon problème mais je la poste ici car je suis inscrit sur ccm et pas ailleurs, et car ça peut servir.
Donc cette erreur appairait avec l'utilisation de PEAR plus précisément de DB.php et pour moi avec pgsql.php.
Je souhaitais donc me connecter mais l'erreur : DB Error: extension not found apparaissait
J'ai cherché pas mal de temps sur le net sans trouver la réponse.
En fait, dans mon cas, il me manquait le paquage "lib-apach2-mod-auth-pgsql". Après l'avoir installé l'erreur a été résolus et entre autre j'ai pus utiliser pg_connect...

2 réponses

Je pense que ça peut servir à d'autre alors voila ce que j'ai du installer moi. J'avais cette erreur pour l'interface web de bacula : Il fallait installer :

apt-get install php5-mysql

En espérant avoir pu aider


-------
Lastico
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57443 internautes nous ont dit merci ce mois-ci

Le sujet date un peu mais en tout cas le fait d'installer php5-mysql a réglé mon problème pour l'interface daloradius.

Merci lastico

Installer le paquage "lib-apach2-mod-auth-pgsql". (pour une connexion sur postgresql)

Merci dans mon cas j'avais oublié le principal pour php (5)
apt-get install lib-apache2-mod-auth-pgsql
apt-get install php5-pgsql
apache2ctl restart.