Enregistrer onglets après avoir fermé Firefox [Résolu/Fermé]

Signaler
-
 FanDeMaxo -
Bonjour à tous.

Voilà mon problème : je voudrais savoir comment (ou s'il y a une technique simple pour) enregistrer les onglets ouverts avec Firefox, pour que quand on ferme Firefox par la suite, et qu'on relance Firefox, les onglets sauvegardés soient réouverts aux pages internet sur lesquelles on était auparavant.

Si vous avez besoin d'autres informations ou d'explications, n'hésitez pas !

Bonne journée à tous, et merci pour vos futures réponses.

19 réponses

Messages postés
582
Date d'inscription
mardi 20 janvier 2009
Statut
Membre
Dernière intervention
1 octobre 2015
303
Outils/Option/Général/Au démarrage de FireFox/Afficher les derniers onglet et fenetre utilisé.
237
Merci

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez Comment Ça Marche

CCM 57033 internautes nous ont dit merci ce mois-ci


génial !
Merci =) =)
merci pour l info
Merci Maxou !
Une solution pour Firefox 4 proposée ici : http://blog.yvoz.net/2011/04/firefox-rouvrir-onglets/

Je copie-colle pour les plus pressés (mais si vous suivez le lien il y a une astuce supplémentaire en fin de page...) :

Pour réactiver l'ouverture des onglets enregistrés:

- Ouvrez votre navigateur firefox
- Dans l'url saisissez ` about:config `
Un avertissement de sécurité va vous informer que `la modification de ces préférences avancées peut être dommageable pour la stabilité, la sécurité et les performances de cette application'. (Bon on se doute que le démarrage de firefox risque d'être un peu plus long lors du chargement des x onglets ;) ).
- Cliquez sur le bouton `Je ferai attention, promis'.
- Dans la zone de filtre saisissez ` browser.showQuitWarning `.
- Par défaut, la valeur est à false (on n'affiche plu l'avertissement permettant d'enregistrer les onglets pour le redémarrage). Il va donc falloir la passer à true.
- Double cliquez sur la ligne ou faites clic droit / inverser.
- Au prochain redémarrage du navigateur l'option sera activée.
Messages postés
1
Date d'inscription
vendredi 14 novembre 2003
Statut
Membre
Dernière intervention
15 septembre 2011

On peut pas faire un vrai lien?
Ca serait plus simple pour cliquer :p
http://www.yvoz.net/2011/04/firefox-rouvrir-onglets/
Salut tous le monde voici le lien d'une réponse d'un pro, je l'ai trouvé sur net

http://www.ballajack.com/comment-configurer-sauvegarde-onglets-fermeture-firefox4
C'est "la" réponse à la question ! Merci Need :-)
thank very much NEED
Merci Ned !!!! C'est LA solution ! :)
génial merci
Merci de ta réponse Madmaxou.

En fait, je voudrais que quand on clique sur la croix rouge de fermeture, qu'ils nous demandent si on veut sauvegarder les onglets, c'est possible ou pas ?
Messages postés
582
Date d'inscription
mardi 20 janvier 2009
Statut
Membre
Dernière intervention
1 octobre 2015
303
Ba en faite, depuis que suis passé à la 3.x.x ba il me le demande plus, sauf qd j'ai la fenetre de téléchargement ouvert, bizarre, malgré que j'ai coché Avertir lors de la fermeture des onglets dans Outils/Options/Onglet
>
Messages postés
582
Date d'inscription
mardi 20 janvier 2009
Statut
Membre
Dernière intervention
1 octobre 2015

La subtilité, c'est qu'ils ne font que nous avertir en cochant cette option, et qu'ils ne proposent pas de sauvegarder !...
Messages postés
582
Date d'inscription
mardi 20 janvier 2009
Statut
Membre
Dernière intervention
1 octobre 2015
303 > Sauce_Soja
Ouais je sais c'est chiant, je me suis fait avoir plus d'une fois alors que j'avais une autre page d'ouvert.
C'est peut être un problème qui est resté et qu'ils n'ont pas corrigé. Mais sur la 2.x.x ça marchait parfaitement.
Messages postés
9
Date d'inscription
samedi 15 décembre 2007
Statut
Membre
Dernière intervention
20 avril 2020
3
Si les onglets s'ouvrent vides, plusieurs causes sont possibles:
- dans les Outils/Options/Général/Démarrage, " choisir Afficher les derniers onglets et fenêtres utilisés"
Mais cela peut être contrarié par l'option suivante, qui efface toute trace de navigation:
dans les Outils/Options/ViePrivée/en bas:
"Toujours effacer mes informations personnelles à la fermeture de Firefox" ; si cette option est cochée,
il n'existera pas de derniers onglets utilisés, puisqu'effacés...
Si cette option est cochée, décochez-la; voir aussi le bouton des détails "Paramètres", si vous souhaitez, plus tard dans vos tests, conserver un élément particulier.

- le nombre d'onglets et de fenêtres restaurés est impressionnant: exemple: 10 fenêtres ouvertes, avec 15 onglets ouverts dans chaque fenêtre. Lors de l'ouverture de Firefox, le panneau avec 2 options "Restaurer la session précédente" ou " Ouvrir une nouvelle session" peut indiquer - je cite - "Oups! C'est embarrassant ! [...]
La restauration peut s'avérer longue à effectuer[...] ."
Le fait de choisir de "restaurer" réouvre toutes les fenêtres les unes après les autres, et, lors de l'ouverture de chacune des fenêtres, Firefox ouvre les onglets de la fenêtre. Ce travail est long, mais la cause principale des onglets vides tient au fait que chaque onglet lance sa requête sur Internet, pour mettre à jour la page. Et il y a blocage à un moment donné, car le nombre de pages interrogeables en même temps n'est pas illimité. Et le système se mélange les pinceaux, vu le nombre de requêtes lancées simultanément.
La solution, pour les quelques onglets qui s'ouvrent vides, est de les sélectionner un par un, et d'actualiser chaque page par la touche F5 du clavier (ou menu Affichage/Actualiser ou touches CTRL + R).

Je ne vois pas d'autres causes logiques possibles, mais j'en apprends tous les jours !

Bonne chance,

Larose51
Voici ce que j'utilise depuis quelques mois (efficace à 100%):

je suis sous Windows, peu importe lequel (xp)
ouvrir le Bloc-Notes
écrire ce qui suit:
taskkill -f -im firefox.exe
"enregistrer" ce fichier texte "sous":
"Bureau"
avec le nom: "firefox_STOP.bat"
c'est tout!

Avant de fermer Firefox avec ce fichier, vérifier que tous vos onglets et toutes vos fenêtres vous conviendront à la prochaine ouverture de Firefox (le terme exact sera "restaurer la session").
Puis aller sur votre Bureau, double-cliquer sur firefox_STOP(.bat), et cela ferme Firefox.

Réouvrez Firefox, choisir TOUJOURS "restaurer la session" et merci qui ? (je plaisante!ne me remerciez pas, svp.Mais faites comme moi: apportez votre savoir aux autres, vous en avez forcément, dans un domaine ou un autre, peut-être dans l'accommodation des brocolis avec des escargots celtes les jours de grand vent !)

Si vous ne disposez pas de taskkill, je l'ai trouvé là (http://h.baarket.free.fr/taskkill.exe ) et à enregistrer dans c:\windows\system32

Alors, heureux ???

.
Bonjour,
pour la disparition de l'invitation à "Enregistrer les onglets avant de fermer", regardez, via le "Gestionnaire des tâches/onglet Processus" si vous n'auriez pas un (ou plusieurs !) "Firefox fantôme" qui serait lancé mais que vous ne verriez pas à l'écran. Pour le savoir : vous "Quittez" FF. Vous regardez ensuite dans l'onglet "Processus" du Gestionnaire des tâches, par ordre alphabétique (c'est plus facile à trouver), si, bien qu'ayant quitté FF, vous n'avez pas encore un Firefox dans la liste ! (normalement, vous ne devriez plus en avoir). Si vous trouvez encore la mention de Firefox dans la liste, vous sélectionnez la (les) ligne(s) et faites "Arrêter le processus". Perso, j'ai ce phénomène de manière intermittente depuis plusieurs mois et je n'ai toujours pas trouvé pourquoi, bien qu'ayant désinstallé puis réinstallé FF. Ceci, sous Vista. Cependant, il n'y a que depuis quelques jours que j'ai rencontré ce nouveau problème d'absence d'invitation de sauvegarde des onglets. Je l'ai résolu en fermant mon fantôme. Evidemment, le fantôme est éradiqué à chaque reboot. Il ne squate mon Windaube (Vista, je le rappelle) que si, en fin d'utilisation, je ne mets le PC qu'en veille ou veille prolongée. L'extinction du PC engendre la fermeture de toutes les applications, donc même celles qui sont lancées en doublon dans le cas de mon FF fantôme. C'est pourquoi, en rebootant, on trouve souvent une heureuse solution à un pb momentané.
CQFD
J'avais le même problème et je pense que je viens de le résoudre...
Va dans outils-> options -> onglet "vie privée" -> décocher l'option "démarrer automatiquement firefox en session de navigation privée"
Voilà j'espère que c'est bon!

bonne journée!!
salut larose51,
pour voir apparaitre cette option,il faut ,pour cela, que dans les règle de conservation ,tu sois sur "utiliser les paramètres personnalisée pour l'historique
mets firefox à jour pour des raisons de stabilité et de sécurité
J'ai la version 3.5.7 (fraichement mise à jour...), et en effet je suis bien sur "utiliser les paramètres personnalisés pour l'historique" comme l'a dit marc64

Bon courage, j'espère que ça suffira!
Marc et Elica, CHAMPIONS !

Je suis (je me sens, je me prétends) CONNAISSEUR dans certains domaines, mais la vie m'apprend encore TOUS LES JOURS qu'on ne sait jamais TOUT...

Encore MERCI de vos réponses aux forums, car VOUS avez eu la meilleure réponse à cette question, pas moi !

ENSEMBLE, ON AVANCE !

ENSEMBLE, ON AVANCE PLUS LOIN!

ENSEMBLE, ON AVANCE PLUS VITE!

ENSEMBLE, ON AVANCE ENSEMBLE ...
??
Chez-moi, à chaque fois que je ferme Firefox, ce dernier me propose de mémoriser les onglets. Il me les rouvre aux mêmes pages, sauf si un mot de passe est nécessaire pour accéder au site mémorisé. Auquel cas, la page d'accueil de ce site m'est proposée (exemple : FAI pour accéder à son courrier perso).

Cordialement

CQFD

Salut,

En réponse à ta question pour avoir la fenêtre "enregistrer et quitter" sur Firefox,
il se trouve que j'ai eu le même problème que toi, elle n'a plus voulu s'afficher du jour au lendemain sans aucune manipulation spécifique de ma part.
Donc, j'ai réfléchis au moment précis où elle avait apparus, et il s'est avéré que cela s'était produit au moment où j'avais dû éteindre mon ordinateur par l'intermédiaire de l'unité centrale (à la sauvage) à cause de 2 anti-virus (à ne surtout pas faire) qui bloquaient toutes les manipulations et au miracle en rallumant mon ordinateur, Firefox me demandait si je voulais restaurer mes onglets, ce que j'ai fait et ensuite en fermant Firefox, il me demander de nouveau si je voulais "enregistrer et quitter".
Encore mieux :
http://www.itbuzzing.com/article-firefox-4-retrouvez-la-fonction-enregistrer-et-quitter-70225516.html
Tout simplement sur le site de Mozilla:
http://support.mozilla.com/fr/kb/Restaurer%20la%20session#w_configurer-la-restauration-de-session
Outils/Option/Général/Au démarrage de FireFox/Afficher les derniers onglet et fenetre utilisé.
ça ne marche pas pour moi, j'ai pourtant été dans la config de firefox changer le browser et rien ne se passe.
De plus je ne peux pas sélectionner "afficher les derniers onglets et fenêtres utilisées" je ne vois pas pourquoi d'ailleurs...
Messages postés
882
Date d'inscription
mardi 5 septembre 2006
Statut
Membre
Dernière intervention
6 mai 2018
15
voila la réponse avec le dernier firefox , je viens de le faire et ça marche très bien



Comment ouvrir les derniers onglets au démarrage de Firefox ?


La manipulation est simple à réaliser. Il suffit d'ouvrir le navigateur Firefox et de cliquer sur "Outils" puis "Options".

Dans le cadre qui s'affiche, sélectionner l'onglet "Général" puis au niveau de "Au démarrage de Firefox", choisir "Afficher les derniers onglets et fenêtres utilisées".

Ainsi, à chaque lancement de Firefox, les dernières pages consultées s'afficheront automatiquement.

https://www.linternaute.fr/hightech/guide-high-tech/1413087-comment-ouvrir-les-derniers-onglets-au-demarrage-de-firefox/
Bonjour, je ne sais pas si je poste ce message au bon endroit. Si tel n'est pas le cas, vous pouvez le déplacer à l'endroit approprié :)
Voila mon problème : j'ai firefox 17.0.1 sur mon pc et quand je ferme Fx normalement, il me rouvre tous les onglets qui étaient ouverts à ce moment lorsque je le rouvre par la suite et ce même si j'ai éteint mon pc entre temps. Dans les options, au démarrage de firefox j'ai bien "afficher ma page d'accueil" mais rien n'y fait, tous les onglets s'ouvrent à nouveau. J'ai lu qu'on pouvait empêcher ça en utilisant la navigation privée, seulement quand je le fais mes mots de passe et mon historique ne sont pas enregistrés ce qui est assez embêtant de devoir sans cesse rerentrer les mots de passe. Si quelqu'un a une solution je suis preneuse parce que là je m'arrache les cheveux pour en trouver une sans succès :P Merci d'avance
bonjour
qui pourra m'aider ? en allant dans outils options général et en cliquant sur "afficher les derniers onglets et fenêtres utilisés" rien à faire
quand j'ouvre ma session j'ai automatiquement deux onglets qui s'ouvrent :
-1er en vert avec un cadenas devant : mozilla fondation us https://www.mozilla.org/fr/firefox/26.0/firstrun/
-2e en orange firefox page de démarrage de mozilla firefox
avant ça marchait bien pourtant
je ne peux pas enregister mes options en page de démarrage
les deux précédents s'ouvrent d'office
je m'y prends comment ?
merci merci merci (je vais craquer...)