Excel convertir nombre en années, mois, jours

Résolu/Fermé
Sinia - 21 oct. 2008 à 16:00
 Gigi - 12 févr. 2012 à 12:04
Bonjour,

Dans un tableau sous excel j'ai

. une case avec la fonction date aujourd'hui()
. une case date d'embauche
. une case avec la formule aujourd'hui - date d'embauche (qui me donne un nombre de jours)

---> Pour ce nombre de jours, par exemple 1526 j'aimerais ajouter une colonne et y mettre une formule qui convertit ces 1526 jours en 4 ans 10 mois 9 jours (<--- réponse fausse j'ai mis ce nombre pour schématiser)

Par avance, merci...

Salutations
A voir également:

7 réponses

youpiii celle-ci fonctionne ! merci merci merci merci merci... depuis le temps que je cherchais, jamais je n'aurais trouvé...
174
jfqld
Messages postés
9081
Date d'inscription
jeudi 18 septembre 2008
Statut
Membre
Dernière intervention
28 mai 2018
122
21 oct. 2008 à 16:09
=SUPPRESPACE(SI(AUJOURDHUI()-D;TEXTE(DATEDIF(D;AUJOURDHUI();"y");"[>1]0"" ans"";
[>]""1 an"";")&TEXTE(DATEDIF(D;AUJOURDHUI();"ym");"[>] 0"" mois "";")&
TEXTE(DATEDIF(D;AUJOURDHUI();"md");"[>1]0"" jours"";[>]""1 jour"";");"0 jour"))
28
Bonsoir !
Je voudrais convertir dans excel le format date exemple : 5 ans 3 mois. Ce format doit être associé ou non avec d'autres cellules. Bref, je voudrais additionner plusieurs cellules de dates en convertissant en années, en mois ou en jours.
Merci pour votre bonne compréhension
Angelo depuis le Cameroun
0
Utilisateur anonyme > Angelo
19 nov. 2009 à 11:45
Bonjour,
" 5 ans 3 mois" n'est pas une date pour excel c'est un texte, les additions et soustractions ne sont donc pas possibles directement.
Par contre les dates sont des nombres et peuvent être ajoutées et soustraites. Les restrictions sont des dates postérieures au 01/01/1900 et l'affichage ###### des résultats négatifs.
Ensuite pour afficher des années des mois et des jours on peut utiliser les fonctions ANNEE, MOIS, JOUR ou une fonction DATEDIF.
0
rubis des iles > Utilisateur anonyme
9 mars 2010 à 16:03
bonjour tonton
J'ai éssayé la formule mais dans la colonne est indiqué "#²NOMBRE!"
j 'ai 2 date au format jj/jj/aaaa ex 30/12/2008 = colonne C2
un autre colonne au meme format jj/jj/aaaa ex 22/12/2008 = colonne D
J'ai donc ensuite une fomule C2-D2 = 313 = colonne E
Comment dois-je faire pour que 313 corresponde a 1 an 3 mois 2 jous par exemple!??

Merci d'avance pour ton aide précieuse je suis au bord du gouffre lol
0
tontong
Messages postés
2512
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
17 mai 2022
1 022 > rubis des iles
9 mars 2010 à 16:17
Bonjour,
Pas de panique!
Je n'ai hélas pas tout compris. Redites nous clairement quelle date est située dans quelle cellule et quelle formule vous avez tenté d'appliquer.
0
rubis des iles > tontong
Messages postés
2512
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
17 mai 2022

11 mars 2010 à 15:04
Bonjour Merci pour votre réponse

Je dois rendre cela demain midi
J'ai essayé la formule : =SI(ET(B5<>"";C6<>"";C6>B5);SI(DATEDIF(B5;C6;"Y")=0;" ";(DATEDIF(B5;C6;"Y")&SI(DATEDIF(B5;C6;"Y")>1;" ans, ";" an, ")))&SI(DATEDIF(B5;C6;"YM")=0;"";DATEDIF(B5;C6;"YM")&" mois, ")&SI(DATEDIF(B5;C6;"MD")=0;" ";(DATEDIF(B5;C6;"MD")&SI(DATEDIF(B5;C6;"MD")>1;" jours ";" jour ")));"")

mais dans la colonne est indiqué "#NOMBRE!"
voila ma formule : =SI(ET(C2-D2;D2;C2>D2);SI(DATEDIF(C2;D2;"A")=0;" ";(DATEDIF(C2;D2;"A")&SI(DATEDIF(C2;;"A")>1;" ans";" an, ")))&SI(DATEDIF(C2;D2;


j 'ai 2 dates au format jj/mm/aaaa - 30/12/2008 = colonne C2
un autre colonne au même format jj/jj/aaaa ex 22/12/2008 = colonne D2
J'ai donc ensuite une formule C2-D2 = 313 = colonne E2
et je voudrait en F2 avoir le nombre de mois jour année,

Comment dois-je faire pour que 313 corresponde a 1 an 3 mois 2 jours par exemple!?? (mais c’est faux)

J’espère que c’est plus clair comme cela ;)
0
jfqld
Messages postés
9081
Date d'inscription
jeudi 18 septembre 2008
Statut
Membre
Dernière intervention
28 mai 2018
122
21 oct. 2008 à 16:47
=(SI(C6+1-B5;TEXTE(DATEDIF(B5;C6+1;"y");"[>1]0"" ans "";[>]""1 an "";")&TEXTE(DATEDIF(B5;C6+1;"ym");"[>] 0"" mois "";")&TEXTE(DATEDIF(B5;C6+1;"md");"[>1]0"" jours "";[>]"" 1 jour "";");" 0 jour"))

essaye celle-ci en remplacant B5 et C6.

C'est une vieille formule que j'avais fait. Et de mémoire je crois que Y correspond à Years en anglais.
Il faut peut etre mettre A pour année en francais

et M = Month ou mois

et D = days pour jours mettre j
4
xalam2
Messages postés
11
Date d'inscription
vendredi 29 mai 2009
Statut
Membre
Dernière intervention
14 novembre 2009

30 mai 2009 à 10:12
Bonjour
jfqld j ai essayé votre formidable formule mais j ai un petit prbléme par exemple si dans la cellule C6 est vide le resultat affiche 109 ans 4 mois 31 jours . Aurez vous une solution pour ce probleme
merci d'avance
0
Utilisateur anonyme > xalam2
Messages postés
11
Date d'inscription
vendredi 29 mai 2009
Statut
Membre
Dernière intervention
14 novembre 2009

30 mai 2009 à 15:20
Bonjour,
Il suffit d'ajouter une condition avec une fonction Si:
=SI(C6<>"";formule actuelle;"données à compléter")
Pour accorder les pluriels des mots "an" et "jour" et supprimer les mots inutiles je trouve la formule suivante plus lisible:
=SI(ET(B5<>"";C6<>"";C6>B5);SI(DATEDIF(B5;C6;"Y")=0;" ";(DATEDIF(B5;C6;"Y")&SI(DATEDIF(B5;C6;"Y")>1;" ans, ";" an, ")))&SI(DATEDIF(B5;C6;"YM")=0;"";DATEDIF(B5;C6;"YM")&" mois, ")&SI(DATEDIF(B5;C6;"MD")=0;" ";(DATEDIF(B5;C6;"MD")&SI(DATEDIF(B5;C6;"MD")>1;" jours ";" jour ")));"")

mais tout est relatif et ce n'est qu'une appréciation personnelle.
0
LTVI > Utilisateur anonyme
9 oct. 2009 à 13:50
Bonjour,

J'ai utilisé votre formule pour avoir des dates en année, mois, jours concernant 243 dates. Ceci me permets d'obtenir des âges d'individus (4 ans, 10 mois et 6jours, par exemple). Or, j'aimerais obtenir un age moyen de ces individus, c'est-à-dire une moyenne de ces donnés. Existe-t-il une formule sur excel pour obtenir une moyenne de plusieurs données "années, mois, jours" ?

Merci par avance

LTVI
0
Utilisateur anonyme > LTVI
9 oct. 2009 à 19:11
Bonjour,
Si les dates de naissances sont en B2:B244 calculer une date de naissance moyenne B250=MOYENNE(B2:B244).
Calculer ensuite un age moyen en appliquant la même formule Datedif entre aujourdhui et B250.
0
tontong
Messages postés
2512
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
17 mai 2022
1 022
11 mars 2010 à 17:20
Bonjour,
Pour la formule : =SI(ET(C2-D2;D2;C2>D2);SI(DATEDIF(C2;D2;"A")=0;" ";(DATEDIF(C2;D2;"A")&SI(DATEDIF(C2;;"A")>1;" ans";" an, ")))&SI(DATEDIF(C2;D2;
c'est à peu près n'importe quoi.
On reprend à la base la syntaxe de DATEDIF(numéro_de_série début;numéro_de_série fin;Intervalle)
Le premier argument doit être la date de début.
L'argument intervalle peut prendre les valeurs: "y" : différence en années "m" : différence en mois "d" : différence en jours "ym" : différence en mois, une fois les années soustraites "yd" : différence en jours, une fois les années soustraites "md" : différence en jours, une fois les années et les mois soustraits

Ce qui donne une une formule de base =DATEDIF(D2;C2;"y")&" ans "&DATEDIF(D2;C2;"ym")&" mois "&DATEDIF(D2;C2;"md")&" jours"
Pour respecter l'orthographe, s'assurer que C2 et D2 ne sont pas vides, et que C2>D2 la formule devient:
=SI(ET(D2<>"";C2<>"";C2>D2);SI(DATEDIF(D2;C2;"Y")=0;" ";(DATEDIF(D2;C2;"Y")&SI(DATEDIF(D2;C2;"Y")>1;" ans, ";" an, ")))&SI(DATEDIF(D2;C2;"YM")=0;"";DATEDIF(D2;C2;"YM")&" mois, ")&SI(DATEDIF(D2;C2;"MD")=0;" ";(DATEDIF(D2;C2;"MD")&SI(DATEDIF(D2;C2;"MD")>1;" jours ";" jour ")));"")
Il reste un peu de temps d'ici demain ;-)
4
rubis des iles
12 mars 2010 à 16:39
merci beaucoup ca marche c est genial
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Après avoir copié-collé et remplacé D par la case de la date d'embauche, et aujourd'hui par la case correspondante, la formule m'indique une erreur avec y... ?
3
Merci pour cette réponse,

Je colle pile comme c'est en substituant aujourd'hui par la case correspondante et D par la case de la date d'embauche ? rien d'autre ? merci encore...
2
jfqld
Messages postés
9081
Date d'inscription
jeudi 18 septembre 2008
Statut
Membre
Dernière intervention
28 mai 2018
122
21 oct. 2008 à 16:24
tout le plaisir est pour moi
2