Comment convertir une date en trimestre [Résolu/Fermé]

Signaler
Messages postés
9
Date d'inscription
lundi 31 mars 2014
Statut
Membre
Dernière intervention
1 décembre 2015
-
 Gio -
Bonjour,

Comment à partir d'une date convertir en trimestre

Ex: Janv = 1 Trim

6 réponses

Messages postés
2808
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
22 octobre 2020
384
Bonjour,

=SI(MOIS(G1)<=3;1;SI(MOIS(G1)<=6;2;SI(MOIS(G1)<=9;3;4)))

la date est en G1

Il doit y avoir quelque chose de plus élégant !
2
Merci

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez Comment Ça Marche

CCM 60511 internautes nous ont dit merci ce mois-ci

Il y a peut etre plus elegant mais au moins ceci fonctionne :-)
Messages postés
9
Date d'inscription
lundi 31 mars 2014
Statut
Membre
Dernière intervention
1 décembre 2015
1
=ENT((MOIS(A2)+2)/3)&" Trim. "&" "&ANNEE(A2)
Messages postés
5965
Date d'inscription
dimanche 10 février 2013
Statut
Membre
Dernière intervention
18 mars 2018
965
Bonjour. Je vois difficilement comment tu peux faire ça. Un trimestre est un intervalle de temps donné, alors qu'une date est un point précis de ce temps.

Par-contre, tu peux définir un trimestre et demander à Excel de déterminer à quel trimestre correspond une date donnée.

Si je vous fait des reproches sur votre post, rendez-vous sur mon profil et lisez la section Devise/Proverbe, ça va vous aider.
Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
817
Bonsoir à tous,

ou encore, pour les Gibis :
=ARRONDI((-MOIS(A2)^11)/246400+(13*MOIS(A2)^10)/44800+(-7*MOIS(A2)^9)/768+(741*MOIS(A2)^8)/4480+(-21489*MOIS(A2)^7)/11200+(95147*MOIS(A2)^6)/6400+(-139943*MOIS(A2)^5)/1792+(619177*MOIS(A2)^4)/2240+(-1026879*MOIS(A2)^3)/1600+(1293669*MOIS(A2)^2)/1400+(-169942*MOIS(A2))/231+243,0) & " Trim. "&ANNEE(A2)

cordialement
Voici sans avoir besoin d'une cellule avec la date du jour :
=SI((MOIS(AUJOURDHUI()))<=3;"T-1";SI((MOIS(AUJOURDHUI()))<=6;"T-2";SI((MOIS(AUJOURDHUI()))<=9;"T-3";"T-4")))
Messages postés
5524
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
21 octobre 2020
500
Bonjour

Une autre idée

=CHOISIR(MOIS(AUJOURDHUI());"Trimestre1";"T-1";"T-1";"T-2";"T-2";"T-2";"T-3";"T-3";"T-3";"T-4";"T-4";"T-4")