Algorithme de calcul de la racine carrée [Résolu/Fermé]

Signaler
-
 Utilisateur -
Bonjour, aidez-moi SVP à trouver la résolution de ce problème : programme qui permet de calculer la racine de x en utilisant une suite .

merçi d'avance

Erica

5 réponses

Messages postés
296
Date d'inscription
mercredi 7 novembre 2007
Statut
Membre
Dernière intervention
30 septembre 2010
30
Bonjour,

t'as bien du essayé de faire quelque chose :) montre nous :)
8
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 56934 internautes nous ont dit merci ce mois-ci

c'est ce que j'ai trouvé mais je sais pas si c'est correcte ou pas
x=1
y=0.5(1+a)
tant que (abs(y-x) supérieure à 0.001)
x=y
y=0.5(x+a/x)
fin tant que
lire y
Messages postés
11066
Date d'inscription
samedi 5 mai 2007
Statut
Contributeur
Dernière intervention
18 octobre 2016
1 688 > Erica
Parfaitement bon ton algorithme.
Remarque : Au début du programme, n'oublie pas : Lire a pour le choix de la racine à calculer.
Et à la fin, à la place de Lire y, mets : afficher y.
Cdlt
>
Messages postés
11066
Date d'inscription
samedi 5 mai 2007
Statut
Contributeur
Dernière intervention
18 octobre 2016

merçi beaucoup fiddy
pas parfait!
mais sa fonctionne!, c'est précision qui est mauvaise
Messages postés
9418
Date d'inscription
dimanche 19 août 2007
Statut
Membre
Dernière intervention
29 mai 2009
1 699
Salut
Bon ! Les étudiants de je sais pas quelle université !
Vous êtes bien gentils mais vous vous débrouillez pour résoudre votre exercice. Si on vous l'a donné, c'est certainement pas pour que quelqu'un le fasse à votre place.
Vous êtes même flemmards au point de pas chercher des éléments de réponse sur le forum alors que la question a déjà posée une paire de fois ? C'est quand même hallucinant ça !
Ciao
Bien joué
ya rabak rani hassale
Messages postés
4
Date d'inscription
samedi 3 janvier 2009
Statut
Membre
Dernière intervention
16 juillet 2016

Bonjour l'Algerien.
Voici une autre solution:
Algorithme racine_carree;
N: entier;
R: réel;
i: entier;
Début
Lire(N);
Si N=0 alors
Ecrire('erreur')
Sinon
R<--1;
Pour i=1 à N faire
R <-- 1/2 * (R + N/R);
i <-- i + 1;
Fin pour;
Écrire ('Racine carée de ', N , '=', R);
Fin si;
Fin.
---------
Bon courage.
J'aime beaucoup les algorithmes, surtout les matrices.
>
Messages postés
4
Date d'inscription
samedi 3 janvier 2009
Statut
Membre
Dernière intervention
16 juillet 2016

Peut tu expliciter R ce quoi, I ce quoi et N ce quoi. Et pourquoi tu as affecter à R la valeur 1
Messages postés
11066
Date d'inscription
samedi 5 mai 2007
Statut
Contributeur
Dernière intervention
18 octobre 2016
1 688 > fortunat
@fortunat : Je doute qu'il réponde, ça date de 2 ans...

Sinon, i est un compteur
Pour N et R :
Écrire ('Racine carrée de ', N , '=', R);
Et R=1, car il faut l'initialiser à 1 pour que l'algorithme marche.
>
Messages postés
4
Date d'inscription
samedi 3 janvier 2009
Statut
Membre
Dernière intervention
16 juillet 2016

Il faut kmm précisé quels sont les variable et les constante
Messages postés
140
Date d'inscription
lundi 14 janvier 2013
Statut
Membre
Dernière intervention
22 avril 2020
13
moi j'aurais mis Lire (N)
Si N<0 alors
Ecrire "Erreur"
Sinon Si N = 0 alors
Ecrire "0"
Sinon
le reste....

etant donné le coté d' un carré.ecrire un algorithme qui calculle sa surface et son périmètre
Messages postés
140
Date d'inscription
lundi 14 janvier 2013
Statut
Membre
Dernière intervention
22 avril 2020
13
c : Entier
p : Entier
s : Entier

Lire (c)
Si c<0 alors
Ecrire "Erreur"
Sinon Si c = 0 alors
p <--0
s <-- 0
Ecrire "Le périmetre est p et la surface est s"
Sinon
p <-- 4 * c
s <-- c*c
Ecrire "Le périmetre est p et la surface est s"
Fsi
Bonjour

De quoi est-tu sûre et de quoi n'es-tu pas sûre là-dedans ?