Word XP - Fusion : Date au format américain [Résolu/Fermé]

Signaler
-
 xerex -
Bonjour,

J'ai fait une fusion dans un document word, depuis une table access.

Ma question concerne un champ date :

Admettons que la date est le 30 juin 2003 ...

Dans la table access, la date est écrite normalement : 30/06/2003
Mais lorsque je fusionne, la date est écrit comme aux USA : 06/30/2003.

Pas moyen de trouver comment régler le format de la date dans un champ de fusion.

Quelqu'un peut-il m'aider ?

Merci d'avance,
Vincent

9 réponses

Bonjour,

J'ai eu le meme soucis. J'ai essayé avec l'astuce de delphine et je n'avais pas les slashs de séparation. J'ai trouvé !

MERGEFIELD "Date" \@ "DD/MM/YYYY" \* MERGEFORMAT

Il faut mettre des / et pas des \ pour qu'ils apparaissent.

Marc.
30
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 86943 internautes nous ont dit merci ce mois-ci

Merci à vous pour le tuyau. Bernard
Merci pour l'information précise et efficace !
Merci ! 10 ans après, toujours aussi utile ! :-)
Merci beaucoup !!! Ca vient de me sauver !
Merci beaucoup Marc.

Vous m'enlevez un tronc d'arbre du pied.

Je n'ai fait qu'un copié/coller de votre formulation :

MERGEFIELD "Date" \@ "DD/MM/YYYY" \* MERGEFORMAT

sous Word 2010 et votre solution fonctionne.

Un grand merci à vous.
Salut vincent,

Dans ton document principal; sélectionne ton champ "date"
fait un clic droit et bascule les "codes champs" puis écris ce qui suit en respectant bien les espaces :

{xxx \@ "dd\mm\yyyy" \* MERGEFORMAT }

xxx étant le nom de ton champ de fusion.

a +
Messages postés
7
Date d'inscription
vendredi 3 novembre 2006
Statut
Membre
Dernière intervention
13 mars 2007
2
bonjour delphine,

je te remercie car c'est ton astuce qui me permet enfin de régler mon problème de date américaine dans mes fusions

en revanche les slachs de séparation n'apparaissent pas.

tu as un petit truc ?

merci d'avance

corinne
Bonjour,

Je viens d'essayer votre formule sur ma base (colonne DATE_DEBUT).
formule utilisée : {MERGEFIELD DATE_DEBUT \@ "dddd dd MMMM yyyy"}
valeur : 5/1/2007
texte affiché : mardi 01 mai 2007

Le format est correct pour moi.

Si vous voulez, envoyez votre base excel et votre fichier word pour qu'on puisse les vérifier.

Ou bien ce que je fais personnellement quand qqch ne marche pas, c'est de refaire un test en partant de zéro (nouveau fichier excel et nouveau fichier word, sans copier coller des valeurs)... Ensuite si çà marche vous ferez par élimination.

HTH
jpbret
YES !!!!!!!!!!!!!!!!!!

Vous êtes vraiment balèze, ça fait des heures que je galère...

Extra ! Merci beaucoup !

A plus.
Un grand merci ... Car il n'y a rien dans la fameuse AIDE de Microsoft

j'ai un peu modifié le format de la date pour obtenir par exemple "samedi 01 mai 2010" : {MERGEFIELD "Date_Échéance"\@ "dddd dd MMMM yyyy" \* MERGEFORMAT}
Bonjour,

J'ai le même problème. j'ai bien introduit la formule suivante
{MERGEFIELD "date"\@ "dddd dd MMMM yyyy" \* MERGEFORMAT}
(date étant le nom de la colonne dans ma base Excel) et ma date reste obstinément en format US...

Où ai-je fait une erreur?

Merci pour vos astuces.
Autre solution...

Dans la base Excel, décomoser la date en 3 colonnes. Dans le doc principal, insérer 3 champs de fusion.

Le tour est joué.
Vous avez été d'une grande aide merci ;D Merci le net, les conseils gratuits, le système D, le profit de l'experience des autres... Tant que j'y suis est ce que ququ'un saurait si une liaison est possible avec Outlook et son agenda pour les alertes (ex: anniversaire, fin de contrat - 3 mois...) ca m'éviterais de saisir 36 fois les même infos!
Bonjour,

D'emblée merci pour votre aide.

J'ai revu, à tête reposée, le problème et ai essayé différentes solutions.

J'ai supprimer le " *MERGEFORMAT " et ai obtenu le résultat souhaité.

Par contre, j'ai constaté que le copier/coller du code ne fonctionnait pas. Je voulais éviter de devoir recopier plusieurs fois celui-ci, à chaque indication de la date...

Décidément, la suite Office est quelquefois bien capricieuse!
Bonjour

J'ai un enorme probleme, dans mon code, le champ "délai" s'affiche en format americain et j'arrive pas a le mettre en francais. je vous transmet le code :

{DATABASE \d "\\\\Serveur\\data\\BD_P2005\\Achat\\relance\\BDD Relance.xlsx" \c "Provider=Microsoft.ACE.OLEDB.12.0;User ID=Admin;Data Source=\\\\Serveur\\data\\BD_P2005\\Achat\\relance\\BDD Relance.xlsx;Mode=Read;Extended Properties=\"HDR=YES;IMEX=1;\";Jet OLEDB:System database=\"\";Jet OLEDB:Registry Path=\"\";Jet OLEDB:Engine Type=37;Jet OLEDB:Database Locking Mode=0;Jet OLEDB:Global Partial Bulk Ops=2;Jet OLEDB:Global Bulk Transactions=1;Jet OLEDB:New Database Password=\"\";Jet OLEDB:Create System Database=False;Jet OLEDB:Encrypt Database=False;Jet OLEDB:Don't Copy Locale on Compact=False;Jet OLEDB:Compact Without Replica Repair=False;Jet OLEDB:SFP=False;Jet OLEDB:Support Complex Data=False" \s "SELECT '#', 'N° commande', 'Référence', 'Désignation', 'Désignation 2', 'Reste à livrer', 'Délai', 'Confirmation' FROM ''Commande retard$'' WHERE (('Nom' = 'AUDILAB SERVICES'))" \l "17" \b "191" \h}
Même B...azar avec des minutes qui s'ajoutent aux minutes en essayant de faire fonctionner ces fichus codes de champs
Comme souvent ça ne marche pas et je me suis mis à ajouter des espaces, à en enlever...
bref...

Ca a fini par faire

avec {MERGEFIELD "DateDeNaissance" \@ "dd\/MM\/yyyy"\* MERGEFORMAT} qui renvoie la date au format 07/01/2005 par exemple

{MERGEFIELD "DateDeNaissance" \@ "dd\ MMMM\ yyyy"\* MERGEFORMAT} renvoie 07 janvier 2005 (les espaces après \ permettent de générer les espaces dans la date renvoyée.

En espérant que cette soupe marche avec d'autres que moi.
L'informatique me semblait être quelque chose de très carré et voilà que ça marche avec une pincée de ci un zeste de ça...

Alain
Bonjour,
La formule :{MERGEFIELD "Date" \@ "dd\ MMMM\ yyyy"\* MERGEFORMAT} fonctionne très bien, toutefois pour une fusion dans Word, la mise à jour du champ n'est pas nécessairement automatique. Il faut revenir au début du processus de fusion ou sauvegarder, sortir du document et revenir pour qu'elle s'applique.