Formule pour jours feries /samedi/dimanche dans un planning

Résolu/Fermé
ptitpanda Messages postés 65 Date d'inscription dimanche 5 août 2012 Statut Membre Dernière intervention 8 avril 2023 - 28 oct. 2022 à 21:12
ptitpanda Messages postés 65 Date d'inscription dimanche 5 août 2012 Statut Membre Dernière intervention 8 avril 2023 - 29 oct. 2022 à 18:05

Bonjour,

J'ai un souci avec une formule toute bête mais je tourne en rond depuis un bon moment.

J'ai un planning comme ci dessous et je souhaite comptabiliser les jours de congés sans les samedis dimanches et jours fériés (que je calcule sur une autre feuille en "Source!C2:C12" et que j'ai même nommé "FERIE")

Donc voici ma formule actuelle toute simple mais même en matricielle je n'arrive pas à ne pas compter les JF:

NB.SI.ENS(AK17:OK17;"Congé";AK6:OK6;"<>SA";AK6:OK6;"<>DI") qui fonctionne (sans JF) 

mais NB.SI.ENS(AK17:OK17;"Congé";AK6:OK6;"<>SA";AK6:OK6;"<>DI";AK5:PK5;"<>" & FERIE) en matricielle ne fonctionne pas

Dans l'exemple ci dessus le résultat devrait être : 3 (lundi étant un jour férié)

Si quelqu'un peut me donner un coup de pouce :)

Merci
Windows / Opera 89.0.4447.39

4 réponses

danielc0 Messages postés 753 Date d'inscription mardi 5 juin 2018 Statut Membre Dernière intervention 19 février 2024 64
29 oct. 2022 à 15:09

Bonjour,

Essaie :

=SOMMEPROD((JOURSEM(AK5:OK5;2)<6)*(AK17:OK17="congé")*(ESTNA(EQUIV(AK5:OK5;FERIE;0))))

Validation matricielle (sauf Excel 365)

Daniel


1
The_boss_68 Messages postés 914 Date d'inscription dimanche 15 novembre 2015 Statut Membre Dernière intervention 19 février 2024 172
29 oct. 2022 à 13:04

Bonjour,

J'ai un souci avec une formule toute bête mais je tourne en rond depuis un bon moment.

Alors si tu tournes en rond depuis un bon moment au lieu de mettre une image qui ne sert à rien, met plutôt un fichier anonymiser sur lequel on peu travailler.

Slts

0
PHILOU10120 Messages postés 6342 Date d'inscription lundi 16 avril 2012 Statut Contributeur Dernière intervention 20 février 2024 787
29 oct. 2022 à 14:53

Bonjour Petitpanda

Une idée dans le fichier

https://www.cjoint.com/c/LJDm0QB23Fk

Pourquoi faire simple ?


0
ptitpanda Messages postés 65 Date d'inscription dimanche 5 août 2012 Statut Membre Dernière intervention 8 avril 2023 8
29 oct. 2022 à 18:05

Hello à tous et merci pour votre aide

@The_boss_68 : ah vrai dire je pensais que pour une simple formule ma copie d'écran suffirait :/

 @PHILOU10120 Désolé ça ne va pas car pour poser des congés ils entrent une date de début et de fin et cela met "Congé" sur toute la durée donc je ne peux pas mettre "F" ou "WE" à la place de "Congé" Les macros derrière sont assez complexes. Merci qd même

@danielc0  Eh bien c'est nickel ça fait exactement ce que je souhaitais :) , j'aurai jamais pensé au ESTNA, je te remercie 

Bonne soirée et bon weekend à tous 

0