Condition sur une formule SIERREUR

Résolu/Fermé
AirSchaeff - 9 juil. 2021 à 16:24
 AirSchaeff - 9 juil. 2021 à 19:04
Bonjour à tous,

J'ai besoin d'aide concernant une formule que je suis entrain de mettre en place.
Celle-ci à pour objectif de renvoyer une valeur présente dans un tableau vers une cellule précise, la formule marche parfaitement seulement j'aimerais rajouter une condition à cette formule pour la rendre optimum.
Le problème est que je n'arrive pas à faire identifier la ligne correspondant à l'extraction par la RecherchV pour y mettre une condition. Pour être plus simple, je veux que la formule renvoi la valeur demandée (colonne 2) à condition et uniquement que si dans cette même ligne la colonne 5 soit égale à la date du jour.

Voici la formule :
=SIERREUR(SI(NB.SI(A45:E79;G44);RECHERCHEV(A14;$A$44:$E$79;2;FAUX);"");"")
A14 = la valeur recherchée dans mon tableau
A45:E79 = Ma plage
G44 = la date du jour avec formule AUJOURDHUI() (facultatif)
Qui va ensuite renvoyée un "NOM" (col2) dans la cellule choisie.

La formule NB.SI n'est peut être pas une bonne option pour ce type de requête. Malheureusement je ne trouve rien sur les forums qui permet d'identifier une cellule correspondant à la valeur à renvoyée pour faire la condition.

Si quelqu'un a déjà eu ce type de requête ou d'autres solutions permettant de m'aider ça serait vraiment super génial.
En espérant avoir été clair.

Merci d'avance.

1 réponse

via55 Messages postés 13988 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 7 décembre 2022 2 532
9 juil. 2021 à 17:25
Bonjour

Essaie plutôt une formule en ce sens :
=SI(RECHERCHEV(A14;$A$44:$E$79;5;0)=AUJOURDHUI();SIERREUR(RECHERCHEV(A14;$A$44:$E$79;2;0);"");"")

Cdlmnt
Via
1
Bonjour,

La formule fonctionne très bien.
Merci !
0