Pb pour intégrer INDIRECT dans RECHERCHEV

Résolu/Fermé
AVEMV Messages postés 9 Date d'inscription dimanche 4 juillet 2021 Statut Membre Dernière intervention 10 juillet 2021 - 4 juil. 2021 à 11:03
Le Pingou Messages postés 12029 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 19 février 2024 - 17 juil. 2021 à 10:46
Bonjour,

Dans un fichier Excel = Onglet (SC - 2105 - SOUSCRIPTION.XLSX]AV - bdd Stats),
j'utilise la fonction :
=SIERREUR(RECHERCHEV(A3;'[SC - 2104 - SOUSCRIPTION.XLSX]AV - bdd Stats'!$A$3:$A$157;1;FAUX);"NEW")

Afin de contrôler la présence de n° de commande dans le fichier du mois précédent
Comme l'AAMM du fichier change chaque mois, j'ai utilisé =CONCATENER pour obtenir chaque fois le nom du fichier du mois précédent : SC - 2104 - SOUSCRIPTION.XLSX dans la cellule E1.

Mais je n'arrive pas à intégrer la formule INDIRECT dans ma RECHERCHEV

Merci pour votre aide
Cordialement

19 réponses

Le Pingou Messages postés 12029 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 19 février 2024 1 424
17 juil. 2021 à 10:46
Merci, pensez de marquer comme RESOLU si c'est le cas
1
Le Pingou Messages postés 12029 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 19 février 2024 1 424
Modifié le 4 juil. 2021 à 11:30
Bonjour,
Essayez comme ceci:
=SIERREUR(RECHERCHEV(A3; INDIRECT(E1&"AV - bdd Stats!$A$3:$A$157");1;FAUX);"NEW")


0
AVEMV Messages postés 9 Date d'inscription dimanche 4 juillet 2021 Statut Membre Dernière intervention 10 juillet 2021
4 juil. 2021 à 11:40
Il m'affiche la formule dans la cellule comme si cela était du texte
Cord.
AVEMV
0
AVEMV Messages postés 9 Date d'inscription dimanche 4 juillet 2021 Statut Membre Dernière intervention 10 juillet 2021
4 juil. 2021 à 12:00
Toutes mes excuses, j'avais laissé trainer un espace devant le signe égal .....!

La formule sort en erreur

Cord.
AVEMV
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Le Pingou Messages postés 12029 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 19 février 2024 1 424
4 juil. 2021 à 13:03
Bonjour,
Alors vous n'avez pas mis le signe = devant ...!
0
AVEMV Messages postés 9 Date d'inscription dimanche 4 juillet 2021 Statut Membre Dernière intervention 10 juillet 2021
4 juil. 2021 à 13:06
Si j'avais bien mis le signe =, mais devant le signe = j'avais mis un espace dans m'en rendre compte ...
Mais la formule sort en erreur
0
Le Pingou Messages postés 12029 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 19 février 2024 1 424
4 juil. 2021 à 14:48
Bonjour,
Est quelle est l'erreur?
0
Le Pingou Messages postés 12029 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 19 février 2024 1 424
Modifié le 4 juil. 2021 à 16:36
Bonjour,
J'ai apporté une petite correction dans le cas de l'extension (.xlsx)
=SIERREUR(RECHERCHEV(A3; INDIRECT("'["&E1&"AV - bdd Stats'!$A$3:$A$157");1;FAUX);"NEW")

0
AVEMV Messages postés 9 Date d'inscription dimanche 4 juillet 2021 Statut Membre Dernière intervention 10 juillet 2021
4 juil. 2021 à 17:13
=SIERREUR(RECHERCHEV($A9; INDIRECT("'["&E$1&"AV - bdd Stats'!$A$3:$A$1000");1;FAUX);"NEW")

J'ai mis des $ afin de pouvoir faire glisser des copies pour toute la colonne
Tous les résultats sortent en : NEW

Cdl
0
Le Pingou Messages postés 12029 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 19 février 2024 1 424
4 juil. 2021 à 17:56
Bonjour,
Il me semble qu'il manquait un signe(])..juste avant (AV...)
=SIERREUR(RECHERCHEV(A3; INDIRECT("'["&E1&"]AV - bdd Stats'!$A$3:$A$157");1;FAUX);"NEW")

0
AVEMV Messages postés 9 Date d'inscription dimanche 4 juillet 2021 Statut Membre Dernière intervention 10 juillet 2021
4 juil. 2021 à 21:58
Bonsoir,
J'ai tjs "NEW" en retour ....
Cdlmt
0
Le Pingou Messages postés 12029 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 19 février 2024 1 424
Modifié le 4 juil. 2021 à 23:10
Bonjour,
C'est étrange, j'ai fait une simulation sur 2 classeurs et tout est ok.
Est.il possible d'avoir une partie de vos classeurs (les 2 compressés zip)sur https://mon-partage.fr/ et poster le lien?
Une image de ma simulation:

Note: essayer d'enregistrer vos 2 classeurs. les fermer et les rouvrir!

0
AVEMV Messages postés 9 Date d'inscription dimanche 4 juillet 2021 Statut Membre Dernière intervention 10 juillet 2021
5 juil. 2021 à 09:29
Bonjour,
Je vous ai envoyé les 2 fichiers hier soir
Cordialement
0
Le Pingou Messages postés 12029 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 19 février 2024 1 424
5 juil. 2021 à 22:39
Bonjour,
Eh bien il manque le lien que vous avez reçu, sans lui rien à faire.
Merci de le mettre sur votre prochain poste.
Note: essayer d'enregistrer vos 2 classeurs. les fermer et les rouvrir!
0
AVEMV Messages postés 9 Date d'inscription dimanche 4 juillet 2021 Statut Membre Dernière intervention 10 juillet 2021
6 juil. 2021 à 08:22
Lien de Téléchargement : https://mon-partage.fr/f/pPwPnTFL/
Merci beaucoup
0
Le Pingou Messages postés 12029 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 19 février 2024 1 424
Modifié le 6 juil. 2021 à 11:04
Bonjour,
Merci, je viens d'ouvrir les fichiers et pour contrôle j'ai modifié les valeurs du fichier source plage A4:A9 et tout est correct dans le fichier cible!


0
AVEMV Messages postés 9 Date d'inscription dimanche 4 juillet 2021 Statut Membre Dernière intervention 10 juillet 2021
10 juil. 2021 à 17:07
Bonjour,
pourriez-vous m'envoyer votre formule utilisée SVP ?
Un grand merci
0
Le Pingou Messages postés 12029 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 19 février 2024 1 424
10 juil. 2021 à 22:40
Bonjour,
Eh bien elle est déjà dans votre classeur (identique à la mienne)
=SIERREUR(RECHERCHEV($A3; INDIRECT("'["&$E$1&"]AV - bdd Stats'!$A$3:$A$1000");1;FAUX);"NEW")
0
Bonjour,
un grand merci pour aide précieuse
Cordialement
0