Validation de données [Résolu]

Signaler
-
Messages postés
699
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
9 juin 2021
-
Bonjour,
Je suis à la recherche d'une méthode de validation de données.
En effet, j'ai les champs A, B et C.
Je veux avoir une liste déroulante de données qui dépend des entrées de A et B.
Par exemple :
Si A=98 et B=84 alors C= liste1
Si A=98 et B=87 alors C= liste2
Les deux listes sont définies dans une autre feuille Excel (chaque liste comprend presque 50 lignes)

Merci de m'aider SVP

3 réponses

Messages postés
17371
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
11 juin 2021
4 638
Bonjour,

si tu n'as que deux conditionnelles de validation

=SI(ET(A2=98;B2=84);Liste1;Liste2)
ou tu joue avec les imbrications

=SI(ET(A2=98;B2=84);Liste1;SI(ET(A2=98;B2=87);Liste2;""))
Merci pour votre réponse, mais je veux avoir la liste déroulante dans la cellule.
La formule que vous avez proposé fonctionne si la validation de données est "personnalisé" .
Mais quand il s'agit d'une liste, un message d'erreur apparait :
la liste source doit être délimitée ou faire référence à une seule ligne ou colonne.
Messages postés
699
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
9 juin 2021
53 > Amal
Bonjour à tous,

La formule de Mike-31, salutations, est à mettre dans la validation de données en choisissant Autoriser une Liste et en mettant cette formule dans Source, à condition que tes liste1 et 2 existent et quelles ne comportent qu'une seule colonne.

Cordialement
Merci beaucoup pour votre aide!
Cela a bien marché :)
Messages postés
17371
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
11 juin 2021
4 638
Re,

Salutation et merci ALS35 d'avoir pris le relais, mais, petite rectification, il est tout a fait possible d'afficher plusieurs colonnes dans une validation.
Seul bémol, les données s'affiche par ligne mais sur une seule colonne.
Si tu es intéressé reviens sur la discussion
Messages postés
699
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
9 juin 2021
53
Salutations Mike-31,

Ah très bien, j'ai retrouvé ta fiche de 2012 !, je ne connaissais pas cette astuce, un peu tirée par les cheveux quand même, mais qui a le mérite d'offrir cette possibilité.

Cordialement