Texte dans une cellule et obtenir des chiffre dans d'autres cellules [Résolu]

Signaler
Messages postés
3
Date d'inscription
mercredi 5 mai 2021
Statut
Membre
Dernière intervention
5 mai 2021
-
Messages postés
3
Date d'inscription
mercredi 5 mai 2021
Statut
Membre
Dernière intervention
5 mai 2021
-
Bonjour,


J'ai un problème un peu complexe...

J'aimerais que lorsque je mets "x" dans la cellule C10 j'obtienne le chiffre 8 dans la cellule O10 et 1 dans la cellule Q10. J'ai donc écrit dans la case O10 : =SI(NB.SI(C10;"x");"8";"") et dans la case Q10 : =SI(NB.SI(C10;"x");"1";""). Jusque là tout est ok.

Le problème c'est que je souhaiterais ajouter d'autre conditions dans les cases O10 et Q10.
- Ex : lorsque je mets "x" dans la cellule D10 cette fois j'obtienne le chiffre 7 dans la cellule O10 et 2 dans la cellule D10.
- Idem : lorsque je mets "x" dans la cellule E10 cette fois, j'obtienne le chiffre 6 dans la cellule O10 et 3 dans la cellule Q10... Ainsi de suite.

Comment puis-je faire ?

Merci infiniment !!!


Configuration: Windows / Chrome 90.0.4430.93

2 réponses

Messages postés
26073
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 juin 2021
5 962
Bonjour
.. pas tout compris, surtout le "ainsi de suite..."?
Par ailleurs le NB.SI pour trouver Xx dans une seule cellule et inutile, de même que mettre les valeurs numériques entre parenthèses
si vous voulez empiler des conditions, placez les dans l'ordre où vous voulez les voir appliquées dans la cellule:
=SI(E10="x";6;SI(D10="x";7;SI(C10="x";8;SI(B10="x";9))))
et fermer avec autant de parenthèses que de SI

Mais si vous avez par exemple un maximum de 10 et des "x" qui "avancent" en cellules toujours contiguës, de A à J inclus, vous pouvez simplifier avec:
=10-NB.SI(A10:J10;"x")
crdlmnt

Messages postés
3
Date d'inscription
mercredi 5 mai 2021
Statut
Membre
Dernière intervention
5 mai 2021

MERCI BEAUCOUP !! Ca a fonctionné !
Bonne journée !!
Messages postés
3217
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
16 juin 2021
450
Bonjour à tous,

Un exemple :
Rappel :
"8"+"2" ==>rien du tout, parce que 8 et 2 sont alors des symboles en texte a cause des "
8+2==>10 ce sont des nombres (construits avec des chiffres)

https://www.cjoint.com/c/KEfjbiRK5WL

Crdlmt
Messages postés
3
Date d'inscription
mercredi 5 mai 2021
Statut
Membre
Dernière intervention
5 mai 2021

MERCI !!! C'est noté ! C'est vrai que ça fonctionne mieux ainsi ;)