Ecart en jours entre date aujourd'hui et une autre date [Résolu]

Signaler
Messages postés
1859
Date d'inscription
samedi 25 février 2012
Statut
Membre
Dernière intervention
28 avril 2021
-
Messages postés
1859
Date d'inscription
samedi 25 février 2012
Statut
Membre
Dernière intervention
28 avril 2021
-
Bonjour,

Pouvez vous m'aider s'il vous plait ?

En D5, j'aimerai une formule afin de calculer le retard en jour(s) entre la date d'aujourd'hui et la date du prochain entretien H5 s'il vous plait ?

https://www.cjoint.com/doc/21_04/KDCmXB2d2jB_entretien-Peugeot-2008.xls

En attente d'une réponse, je vous remercie.
Cordialement.



Configuration: Windows / Chrome 90.0.4430.93

2 réponses

Messages postés
3249
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
16 mai 2021
911
Bonjour

un oubli des parenthèses après AUJOURDHUI() et pour éviter l'erreur si H5 est vide

=SI(H5<>"";SI(AUJOURDHUI()<=H5;"";AUJOURDHUI()-H5);"")


La formule en H5 peut être modifiée ainsi

=SI(E5<>"";MOIS.DECALER(E5;C5*12);"")


Cordialement
Messages postés
1859
Date d'inscription
samedi 25 février 2012
Statut
Membre
Dernière intervention
28 avril 2021
333
Bonjour et merci pour votre réponse.

Par contre, j'aimerai avoir que les jours dépassés (par exemple, -16 ne m'intéresse pas).

Comment procéder s'il vous plait ?

Merci d'avance.
Cordialement.
Messages postés
3249
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
16 mai 2021
911
je viens justement de corriger la formule dans ma réponse précédente ; ajout de la condition si la date du jour est <=H5
Cordialement
Messages postés
1859
Date d'inscription
samedi 25 février 2012
Statut
Membre
Dernière intervention
28 avril 2021
333 >
Messages postés
3249
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
16 mai 2021

Merci beaucoup, c'est parfait.

Je vous souhaite une bonne journée.
Prenez soin de vous.

Cordialement.