Ecart en jours entre date aujourd'hui et une autre date

Résolu/Fermé
mj1974 Messages postés 1868 Date d'inscription samedi 25 février 2012 Statut Membre Dernière intervention 11 novembre 2022 - 28 avril 2021 à 14:56
mj1974 Messages postés 1868 Date d'inscription samedi 25 février 2012 Statut Membre Dernière intervention 11 novembre 2022 - 28 avril 2021 à 15:53
Bonjour,

Pouvez vous m'aider s'il vous plait ?

En D5, j'aimerai une formule afin de calculer le retard en jour(s) entre la date d'aujourd'hui et la date du prochain entretien H5 s'il vous plait ?

https://www.cjoint.com/doc/21_04/KDCmXB2d2jB_entretien-Peugeot-2008.xls

En attente d'une réponse, je vous remercie.
Cordialement.



Configuration: Windows / Chrome 90.0.4430.93

2 réponses

PapyLuc51 Messages postés 3800 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 1 décembre 2022 1 198
Modifié le 28 avril 2021 à 15:37
Bonjour

un oubli des parenthèses après AUJOURDHUI() et pour éviter l'erreur si H5 est vide

=SI(H5<>"";SI(AUJOURDHUI()<=H5;"";AUJOURDHUI()-H5);"")


La formule en H5 peut être modifiée ainsi

=SI(E5<>"";MOIS.DECALER(E5;C5*12);"")


Cordialement
0
mj1974 Messages postés 1868 Date d'inscription samedi 25 février 2012 Statut Membre Dernière intervention 11 novembre 2022 361
28 avril 2021 à 15:35
Bonjour et merci pour votre réponse.

Par contre, j'aimerai avoir que les jours dépassés (par exemple, -16 ne m'intéresse pas).

Comment procéder s'il vous plait ?

Merci d'avance.
Cordialement.
0
PapyLuc51 Messages postés 3800 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 1 décembre 2022 1 198
28 avril 2021 à 15:39
je viens justement de corriger la formule dans ma réponse précédente ; ajout de la condition si la date du jour est <=H5
Cordialement
0
mj1974 Messages postés 1868 Date d'inscription samedi 25 février 2012 Statut Membre Dernière intervention 11 novembre 2022 361 > PapyLuc51 Messages postés 3800 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 1 décembre 2022
28 avril 2021 à 15:53
Merci beaucoup, c'est parfait.

Je vous souhaite une bonne journée.
Prenez soin de vous.

Cordialement.
0