La fonction si imbriquée [Résolu]

Signaler
-
 Jod -
Bonjour à tous, besoin d'aide.je veux créer un tableau, pour comparer deux cellule avec plusieurs termes différents mais désignant la même valeur, par exemple j'ai tomate=légume, soit si B2=tomate et C2=légume ou B2=légume et C2=tomate, renvoie dans D2 "ok" si différent revoie "revoir"



Configuration: Windows / Chrome 43.0.2357.124

4 réponses

Messages postés
32243
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
25 juin 2021
7 765
il est toujours préférable d'exposer un problème, une question, en totalité. Car une solution qui fonctionne avec 2 mots ne sera généralement pas utilisable s'il y en a 20 ;-)
justement, car à trois termes, il a fallu établir une relation identique avec un même terme sur les deux cellules sur la fonction ET: ET(B2="tomate";C2="tomate") par exemple ainsi que pour les autres.
Messages postés
32243
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
25 juin 2021
7 765
bonjour,

voir :
=SI(OU(ET(B2="tomate";C2="legume");ET(C2="tomate";B2="legume"));"OK";"revoir")


Merci beaucoup jee pee, je viens de l'appliquer, ça marche.
je vais essayer pour plus de termes encore.
ça de même marché pour trois termes
=SI(OU(ET(B2="tomate";C2="legume");ET(C2="tomate";B2="legume");ET(B2="Solanum lycopersicum";C2="legume");ET(C2="Solanum lycopersicum";B2="Solanum lycopersicum");ET(B2="tomate";C2="Solanum lycopersicum");ET(C2="tomate";B2="Solanum lycopersicum");ET(C2="tomate";B2="tomate");ET(C2="legume";B2="legume");ET(C2="tomate";B2="Solanum lycopersicum"));"OK";"revoir")