Comment contourner la fonction FILTRE

Signaler
-
Messages postés
2811
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
25 octobre 2020
-
Bonjour,
s'il vous plait pouvez me dire comment contourner la fonction filtre , car avec excel 2013 la fonction filtre ,ne marche pas
normalement je suis censé avoir :
=SI(B1=" ";" ";SI(NB.SI(B13:B18;B1)=1;B1;FILTRE(B13:B18;A13;A18=$B$1;" ")))
comment contourner la fonction FILTRE pour avoir le même résultat.
Merci d'avance



Configuration: Windows / Chrome 86.0.4240.75

2 réponses

Messages postés
2811
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
25 octobre 2020
385
Bonjour à tous,

Avec la fonction donnée==>filtre==>filtre avancé

Crdlmt
Merci, mais comment je l'introduis dans ma formule de départ ?
Messages postés
2811
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
25 octobre 2020
385
Tu demandes de contourner, on contourne, à l'ancienne et à la main !

maintenant, avec une formule :
=SI(B1=" ";" ";SI(NB.SI(B13:B18;B1)=1;B1;FILTRE(B13:B18;A13;A18=$B$1;" "))) ;
tu remplaces filtre() par :
sierreur(index($B$13:$B$18;petite.valeur(si($A$13;$A$18=$B$1;ligne($A$13;$A$18)-3);lignes($1:1)));"")
C'est une formule matricielle, donc a valider par
Maj+Ctrl+Entrée (les 3 doigts en même temps) pour faire apparaitre les accolades.
Elle doit s'afficher automatiquement entre accolades dans la barre de formule, et être re-validée de la même façon à chaque fois qu'on y touche.

et tu descends ta formule en tirant sur la croix.


Crdlmt