Formule complexe alliant SI ; ET ; ESTVIDE [Résolu]

Signaler
-
 Ivan87000 -
Bonjour,

Je bloque sur l'établissement d'une formule dans mon fichier excel. Je travaille sur un plan d'action et j'ai réussi à faire apparaître le fait qu'une action était en retard ou OK en fonction de la date prévue de l'action et de la date du jour (AUJOURDHUI). J'ai ainsi la formule suivante :
=SI(O3-AUJOURDHUI()<1;"En retard";"Ok")
O3 est la date prévue de l'action.

Seulement je souhaite à présent qu'avec l'incrémentation d'une date de clôture de l'action (dans une autre cellule, en R3), cette dernière ne soit plus en retard mais OK.
J'essaie de combiner la formule SI, une formule ET, ainsi qu'une formule ESTVIDE, mais je n'arrive pas à concrétiser cela.
J'ai la formule suivante à ce stade :
=ET(SI(O3-AUJOURDHUI()<1;);ESTVIDE(R3);"En retard";"Ok").
Seulement celle-ci m'affiche "FAUX" et non pas En retard ou Ok.
Si quelqu'un à la formule magique ?
D'avance merci
(PS : désolé je n'ai pas pu charger d'image ou de fichier)

5 réponses

Messages postés
3286
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
19 juin 2021
929
Bonjour

Parce que dans cette formule le ET et la parenthèse fermante ne sont pas placés aux bons endroits

=SI(ET(O3-AUJOURDHUI()<1;ESTVIDE(R3));"En retard";"Ok")

ESTVIDE n'est peut-être pas utile éventuellement à remplacer par R3=""

Quelle est la condition voulue pour O3 ??

Cordialement
Merci PapyLuc51,

Ta première formule fonctionne effectivement, et si j'utilise cette formule :
=SI(ET(O4-AUJOURDHUI()<1;R4="");"En retard";"Ok")
Cela fonctionne aussi, avec une formule qui est plus light visuellement du coup.

En O3 j'avais une date rentrée manuellement (mon échéance prévue).

Je te remercie grandement pour cette aide, si rapide qui plus est, et j'espère que cela aidera d'autres personnes qui liront ce post.

Bonne journée à toi et encore merci.
Messages postés
3286
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
19 juin 2021
929
Si le problème est résolu, alors cliquer sur le bouton vert en tête de la discussion.

Bonne continuation

Cordialement
PapyLuc51,

Petite question bonus (je n'avais pas anticiper ce besoin), à partir de la formule suivante :
=SI(ET(O2-AUJOURDHUI()<1;R2="");"En retard";"Ok")
qui se trouve dans ma cellule Q2, saurais-tu ajouter ce qu'il manque pour que rien ne s'affiche si ma cellule O2 est vide ? Lorsque je développe la formule sur la colonne et que je n'ai pas renseigné de date d'échéance, j'ai les termes "En retard" qui s'affichent, or je souhaiterais que lorsque O2 est vide, Q2 reste vide aussi.

En te remerciant par avance.

Ivan
Messages postés
3286
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
19 juin 2021
929
Rajouter un SI() au début

Si O2 n'est pas vide, alors ont applique la formule, sinon on inscrit rien

Concrètement ça fait

=SI(O2<>"";SI(ET(O2-AUJOURDHUI()<1;R2="");"En retard";"Ok");"")

Cordialement
PapyLuc51,

De nouveau une réponse rapide, claire et professionnelle. J'ai exactement le résultat désiré.
Merci de ce support pour la communauté.

Bonne journée