SublimeText et BrowserSync - problème pour lier le CSS

Signaler
Messages postés
63
Date d'inscription
lundi 10 février 2020
Statut
Membre
Dernière intervention
17 juillet 2021
-
Messages postés
33163
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
1 août 2021
-
Bonjour,

J'utilise SublimeText et BrowserSync afin de rafraichir automatiquement ma page web. Mon "index.html" est donc situé dans "http://localhost:3000/index.html".

Je crée un site web, et je suis amené à avoir plusieurs fichiers HTML. Je décide donc de les placer dans un dossier nommé "HTML". Mon fichier CSS est dans un dossier nommé "CSS".


Mon doctype est le suivant :
<!DOCTYPE html>
<html lang="fr">
<head>
 <meta charset="UTF-8">
 <meta name="viewport" content="width=device-width, initial-scale=1.0">
 <title>Christophe DUBOIS</title>
 <link rel="stylesheet" href="../css/style.css>
</head>


En double cliquant sur "index.html", tout marche niquel. Par contre, en affichant mon site avec Browser Sync, j'obtiens l'erreur suivante (et le fichier css n'est pas lancé) :

Refused to apply style from 'http://localhost:3000/css/style.css' because its MIME type ('text/html') is not a supported stylesheet MIME type, and strict MIME checking is enabled.


Je ne comprend pas. Quel réglage de BrowerSync devrais-je paramétrer pour ce ça fonctionne ?
Merci.

2 réponses

Messages postés
33163
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
1 août 2021
3 647
Bonjour,

Pour commencer, il manque une quote sur ta ligne
 <link rel="stylesheet" href="../css/style.css>

Il faudrait à la place
 <link rel="stylesheet" href="../css/style.css">

Messages postés
63
Date d'inscription
lundi 10 février 2020
Statut
Membre
Dernière intervention
17 juillet 2021

Oups ! Petit soucis quand j'ai copié le code dans CCM. C'est corrigé, mais le problème ne venait pas de là.
Messages postés
33163
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
1 août 2021
3 647
Ton fichier css commence t-il par des commentaires ? Si oui, retire les.
Peux tu également t'assurer qu'il est bien enregistré en utf8 sans bom ( voir chapitre 1 de ce lien : https://www.commentcamarche.net/faq/47069-html-php-caracteres-accentues-et-l-utf8 )

Après... ben.. je ne connais BrowserSync ... et vu que ton css fonctionne sans.. impossible de te répondre mieux.