MFC à deux conditions [Résolu]

Signaler
-
 Cecilie -
Bonjour à tous,

Je parcours les forums depuis plusieurs jours maintenant et je reste bloquée.

Dans mon tableau Excel, j'ai une première condition :

1. Si ma cellule L2 contient quelque chose (une date) alors la ligne entière doit devenir blanche
Traduite ainsi =$L2<>""

Puis une seconde condition :

2. Si ma cellule B2 contient l'un des fournisseurs suivants MERAULT Stéphane, Yanushko George B ou DI-TECH, alors ma ligne doit venir rouge
Traduite ainsi : =SI(OU($B2="MERAULT Stéphane";$B2="Yanushko George B";$B2="DI-TECH");1;0)

J'aimerai réussir à imbriquer les deux conditions car depuis que j'ai ajouté la seconde condition, la première ne fonctionne plus dans les lignes contenant les fournisseurs susmentionnés.

PS : je ne sais pas comment vous joindre mon Excel

Merci par avance à tous ceux qui vont m'aider à résoudre ce problème :)

Bien à vous.

5 réponses

Messages postés
3007
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
18 janvier 2021
836
Bonjour,

Pour joindre un fichier
Aller dans https://www.cjoint.com/
Cliquer sur "PARCOURIR" pour sélectionner le classeur ou "FAIRE UN GLISSER DEPOSER" dans la fenêtre ;
Clic sur le bouton "CREER LE LIEN" ;
"CLIC DROIT" sur le lien créé "COPIER L'ADRESSE DU LIEN" ;
Sur le post Clic droit "COLLER".

ou dans https://mon-partage.fr/

Donner des exemples de ce qui est attendu sur le fichier test

Cordialement
Messages postés
3007
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
18 janvier 2021
836
Bonjour,

Salutations ALS35, parfait pour les MFC

Ma petite touche personnelle :

Modification des formules en colonnes F et H pour éclaircir le tableau

https://www.cjoint.com/c/JLtfxBT3XOT

Je préconise aussi (si toutefois c'est possible) :

La mise en place d'une LD en colonne B et une RECHERCHEV() en colonne E avec ce genre de tableau (hors champs ou sur une autre feuille)


Colonne de gauche nommée "fournisseurs" le tableau complet nommé "echeance"
Colonne B / validation des données / liste / =fournisseurs

colonne E (pour E2) =SI(D2="";"";D2+RECHERCHEV(B2;echeance;2;0)) ; ça éviterait d'écraser les formules

Cordialement
Encore BRAVO !!

Et merci pour cette suggestion que je vais intégrer de suite dans mon fichier :)
Bonjour PapyLuc51,

Voici le lien vers mon fichier

https://www.cjoint.com/c/JLshI1KZnUg

Merci pour votre aide :)
Messages postés
3007
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
18 janvier 2021
836
OK je m'y met dans la journée,
A première vue la coloration rouge peut être combinée et la couleur blanche serait inutile;

J'ai déjà modifié la formule en colonne H pour que la lecture soit plus aisée ; inutiles de mettre les mois ou les jours s'il y en a pas

=SI(E2="";"";SI(DATEDIF(E2;AUJOURDHUI();"YM")>0;DATEDIF(E2;AUJOURDHUI();"YM")&" mois et ";"")&SI(DATEDIF(E2;AUJOURDHUI();"MD")>0;DATEDIF(E2;AUJOURDHUI();"MD")&SI(DATEDIF(E2;AUJOURDHUI();"MD")>1;" jours";" jour");""))


Je reviens dès que j'ai trouvé quelque chose et je suis sûr que les camarades planchent déjà.

Cordialement
Merci pour cette première correction :)

bon courage pour la suite hihihihi
Messages postés
583
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
15 janvier 2021
34
Bonjour à tous,

Un essai en feuille 2 pour les lignes 2 à 15.
L'ordre des MFC est important.

https://www.cjoint.com/c/JLsoIVPaCNC

Cordialement
>
Messages postés
583
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
15 janvier 2021

Merci beaucoup ALS35 !
Bonjour PapyLuc51, bonjour ALS35 :)

Je viens de prendre connaissance de vos réponses...

Et je dirai BRAVO !!! Moi qui pensais me débrouiller... Je me dis que je suis bien loin du compte !!

Merci 1000 fois d'avoir pris le temps de me répondre et de chercher, bien plus que des solutions !!

Belle journée à vous et surtout passez de belles fêtes de fin d'année :)