Erreur dans ma formule? [Résolu]

Signaler
Messages postés
4
Date d'inscription
mardi 10 novembre 2020
Statut
Membre
Dernière intervention
14 novembre 2020
-
Messages postés
2858
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
14 novembre 2020
-
Bonjour,

Je ne trouve pas l'erreur dans ma formule.

Ce que je souhaite faire:

Afficher en P5 "C" ou "NC" en fonction des règles suivantes:

(45<B6<48 et 115<C6<118) ou (85<D6<88 et 121<E6<123) ou (10<F6<13 et 112<G6<115) ou (30<H6<33 et 90<I6<93) ou (35<J6<38 et 100<K6<103) ou (40<L6<43 et 95<M6<98) ou (30<N6<33 et 90<O6<93)

=> afficher C si les règles sont respectées
=> sinon afficher NC

Sachant qu'en majorité un seul couple sera présent, d'où la présence de la formule OU().

Ma formule:
=SI(ET(SI(ET(B6>=45;B6<=48);"C";SI(ET(C6>=115;B6<=118);"C";OU(SI(ET(D6>=85;D6<=88);"C";SI(ET(E6>=121;B6<=123);"C";OU(SI(ET(F6>=10;F6<=13);"C";SI(ET(G6>=112;G6<=115);"C";OU(SI(ET(H6>=30;H6<=33);"C";SI(ET(I6>=90;I6<=93);"C";OU(SI(ET(J6>=35;J6<=38);"C";SI(ET(K6>=100;K6<=103);"C";OU(SI(ET(L6>=40;L6<=43);"C";SI(ET(M6>=95;M6<=98);"C";OU(SI(ET(N6>=30;N6<=33);"C";SI(ET(O6>=90;O6<=93);"C";"NC"))))))))))))))))))))))

Si vous avez besoin d'autres informations n'hésitez pas.

Si vous pensez qu'il existe un meilleur moyen, plus simple d'arriver au même résultat je suis preneur.

Bien a vous

NP

11 réponses

Messages postés
2858
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
14 novembre 2020
394
Bonjour à tous,

A vue de nez, ta formule pour fonctionner, doit se présenter sous la forme :
si(ou(ET(B6>=45;B6<=48);ET(C6>=115;c6<=118); etc.......;"c";"nc")
et certaines conditions sont fausses (ET(C6>=115;B6<=118) (ET(E6>=121;B6<=123).
sinon, mets d'autres explications sur ton fichier et mets le sur https://www.cjoint.com/ et revient donner le lien sur le forum

Crdlmt
J'ai essayé avec les modifications que tu m'as suggéré, la formule fonctionne mais ne répond pas aux exigences.

https://www.cjoint.com/c/JKkvEZRVD5p

Les exigences: chaque colonne (2,1,5,9,6,7,10) a des critères t et T° différents.
Et la ça ne fonctionne pas car le critère T° est faux et ça m'affiche "C".

Cordialement
Messages postés
23631
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
14 novembre 2020
6 461
Bonjour,

=> afficher C si les règles sont respectées ???
Toutes les règles ou au moins une comme le laisse supposer ta formule ???

Sachant qu'un ET est un * et un OU un +, tu peux l'écrire de façon plus légère et je trouve plus lisible ainsi :
=SI((B6>=45)*(B6<48)+(C6>=115)*(C6<118)+(D6>=85)*(D6<=88);"C";"NC")

J'en ai mis que 3, à toi de coller la suite.
Que tu peux écrire sous forme matricielle pour encore plus de lisibilité :
=SI(SOMMEPROD(((B6:D6)>={45\115\85})*((B6:D6)<{48\118\88}));"C";"NC")

à tester et contrôler bien sûr

Attention, il y a divergence entre le texte et ce que tu as fait.
Tu annonces B6<48 et dans ta formule c'est B6<=48 ?!?
eric

Edir : une erreur de ref s'était glissée dansma formule, corrigé

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Bonjour,

C pour conforme, NC pour non conforme.

Dans mon cas, la conformité c'est:

(45<=B6<=48 et 115<=C6<=118) ou (85<=D6<=88 et 121<=E6<=123) ou (10<=F6<=13 et 112<=G6<=115) ou (30<=H6<=33 et 90<=I6<=93) ou (35<=J6<=38 et 100<=K6<=103) ou (40<=L6<=43 et 95<=M6<=98) ou (30<=N6<=33 et 90<=O6<=93)

"ou" dans le sens où pour chaque ligne deux colonnes seulement seront remplies donc quand les colonnes sous le 2 sont remplies avec 45 et 116 par exemple et que toutes les autres sont vides, je veux un affichage "C". En revanche si j'ai 45 et 152, je veux un affichage "NC", ce qui n'est pas le cas.

NB: au temps pour moi c'est bien inferieur ou égal partout

Cdlt,
Nicolas
Messages postés
23631
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
14 novembre 2020
6 461
J'ai édité mon post, tu peux tester

PS : un fichier dans un forum excel c'est un xls, que veux-tu qu'on fasse d'une image ? Du photoshop pour corriger ta formule ?
Messages postés
4
Date d'inscription
mardi 10 novembre 2020
Statut
Membre
Dernière intervention
14 novembre 2020

Bonjour,

Cela ne fonctionne pas.

Visiblement je ne me fais pas comprendre correctement, je recommence sur les conditions:


Il y a 2 colonnes (1 et 2), chaque colonne est subdivisée en 2 sous-colonnes (temps et température) identiques pour chaque colonne.

Dans la formule les conditions de t et T°C sont liées pour chaque colonne : il faut que les deux soit vraies -pour la colonne 1 par exemple- pour afficher "C" pour conforme. Si l'une des deux est fausse : afficher "NC" pour non conforme.

- Ma formule qui ne fonctionne pas :

=SI(ET(SI(ET(B6>=45;B6<=48);"C";SI(ET(C6>=115;C6<=118);"C";OU(SI(ET(D6>=85;D6<=88);"C";SI(ET(E6>=121;E6<=123);"C";OU(SI(ET(F6>=10;F6<=13);"C";SI(ET(G6>=112;G6<=115);"C";OU(SI(ET(H6>=30;H6<=33);"C";SI(ET(I6>=90;I6<=93);"C";OU(SI(ET(J6>=35;J6<=38);"C";SI(ET(K6>=100;K6<=103);"C";OU(SI(ET(L6>=40;L6<=43);"C";SI(ET(M6>=95;M6<=98);"C";OU(SI(ET(N6>=30;N6<=33);"C";SI(ET(O6>=90;O6<=93);"C";"NC"))))))))))))))))))))))



- Proposition N°1



Ne fonctionne pas, on note la valeur fausse de T° pourtant affichage de "C"

-Proposition N°2



Même conclusion que précédemment.

D'avance merci de vos réponses

PS à ériiic: peut-être parce que je ne sais pas héberger un fichier excel ici? alors au lieu de réagir comme ça dis moi comment faire, restons constructifs...
Messages postés
23631
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
14 novembre 2020
6 461
Bonjour,

peut-être parce que je ne sais pas héberger un fichier excel ici? alors au lieu de réagir comme ça dis moi comment faire, restons constructifs...
C'est un gag ?
Ca t'a été indiqué au post 1, auquel tu as répondu en y déposant une image...
eric
Messages postés
2182
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
14 novembre 2020
894
Messages postés
4
Date d'inscription
mardi 10 novembre 2020
Statut
Membre
Dernière intervention
14 novembre 2020

Messages postés
2182
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
14 novembre 2020
894
Bonsoir
une autre approche
ici
Messages postés
523
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
14 novembre 2020
23
Bonjour à tous,

Classique avec formule
=SI(OU(ET(B6>=46;B6<=48;C6>=115;C6<=118);ET(D6>=85;D6<=88;E6>=121;E6<=123);ET(F6>=10;F6<=13;G6>=112;G6<=115);ET(H6>=30;H6<=33;I6>=90;I6<=93);ET(J6>=35;J6<=38;K6>=100;K6<=103);ET(L6>=40;L6<=43;M6>=95;M6<=98);ET(N6>=30;N6<=33;O6>=90;O6<=93));"C";"NC")


Cordialement
Messages postés
4
Date d'inscription
mardi 10 novembre 2020
Statut
Membre
Dernière intervention
14 novembre 2020

Merci à vous, vos deux solutions fonctionnent merci

Cordialement
Messages postés
2858
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
14 novembre 2020
394
Ça ressemble étrangement a la réponse du post 1