Sheets pour : si date 2 absente : calculer ajourd'hui [Résolu]

Signaler
-
Messages postés
25375
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2020
-
Bonjour,

Je fais un fichier sur Google Sheets qui compte le nombre de jours entre 2 dates (Arrivée et Départ).
Mais je ne sais pas comment faire en sorte que, s'il n'y a pas de date inscrite dans la colonne Départ, la colonne qui calcule le nombre de jours considère que c'est aujourd'hui.

Pour le moment c'est juste =DATEDIF(C3;D3;"D"). Mais je veux ajouter "si D3 vide = date d'aujourd'hui".

Merci beaucoup !

2 réponses

Messages postés
25375
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2020
5 525
Bonjour
=DATEDIF(C3;SI(D3="";AUJOURDHUI();D3);"d")
crdlmnt
Merci beaucoup !
Mais j’ai nouveau problème : si les 2 dates sont vides : c’est un chiffre dans les 40000 qui s’affiche...
Pour que ce soit 0 si les 2 sont vides, vous savez ?
Encore mille merci !
Messages postés
25375
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2020
5 525
Alors il suffit d'éliminer s'il n'y a pas de date de départ:
=SI(C3="";"";DATEDIF(C3;SI(D3="";AUJOURDHUI();D3);"d"))
crdlmnt