Somme si couleur [Résolu]

Signaler
Messages postés
26
Date d'inscription
vendredi 2 octobre 2009
Statut
Membre
Dernière intervention
9 septembre 2020
-
Messages postés
26
Date d'inscription
vendredi 2 octobre 2009
Statut
Membre
Dernière intervention
9 septembre 2020
-
Bonjour,

Je cherche à faire la somme des cellules qui sont colorisées via une MFC mais je ne trouve pas de formule pour ça.
Pour expliquer, j'ai des cellules en jaunes ou en bleu suivant si c'est des jours en week-end ou des jours férié et je dois les calculer à part, pour appliquer une majoration, car la tarification n'est pas la même.
Merci par avance au retour qui me seront fait, et bonne journée.

PS: J'ai cherché un peu partout, mais j'ai rein trouvé, et j'ai l'impression que beaucoup sont dans mon cas :/

9 réponses

Messages postés
840
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
9 septembre 2020
173
Bonjour,
Si les couleurs sont automatisées par une MFC, il suffit de prendre en compte la formule qui les gèrent et des la combiner avec une NB.SI()
Messages postés
26
Date d'inscription
vendredi 2 octobre 2009
Statut
Membre
Dernière intervention
9 septembre 2020
1
Je dois certainement faire une erreur mais cela ne fonctionne pas.

Ma MFC est: =JOURSEM($C12;2)>5
Donc suivant votre principe, j'utilise la formule =NB.SI(F12:F42;"=JOURSEM($C12;2)>5")
Elle est ou mon erreur?
Merci par avance.
Messages postés
840
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
9 septembre 2020
173
Re,

Utilise donc cette formule
=SOMMEPROD(N(JOURSEM(F12:F42;2)>5))
Messages postés
26
Date d'inscription
vendredi 2 octobre 2009
Statut
Membre
Dernière intervention
9 septembre 2020
1
Heu non cela ne fonctionne pas :/
Je pense que j'ai dû oublier de donner une information importante, mais je ne vois pas quoi.
Car là, cela me compte le nombre de cellules de la colonne, peu importe ce qu'il y a dedans.
Messages postés
840
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
9 septembre 2020
173
Re,
Regarde sur cet exemple
https://mon-partage.fr/f/A1woAgpD/
Messages postés
2126
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
9 septembre 2020
281
Bonjour,

En admettant que les jours soient dans la plage C1:C31
formule pour comptabiliser le nombre de week-end
=SOMMEPROD((JOURSEM($C$1:$C$31;2)>5)*1)



formule pour compter les autres jours
=SOMMEPROD((JOURSEM($C$1:$C$31;2)<6)*1)



s'il y a des jours fériés à exclure au même titre que les week-end, il faut les ajouter dans la première formule et les soustraire pour la seconde.

Cdlt
Messages postés
26
Date d'inscription
vendredi 2 octobre 2009
Statut
Membre
Dernière intervention
9 septembre 2020
1
@ M-12 et Frenchie83,
Merci à tous les deux pour votre retour, mais cela me calcule le nombre de cellules colorisées, et non la somme des montants qui sont dans ces cellules.
Et c'est là mon problème.
Une autre idée à me proposer.
Merci encore pour votre aide.
Messages postés
2126
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
9 septembre 2020
281
Comme vous ne donnez de précision sur ce qui est recherché, il y a de fortes chances qu'on réponde à côté ou de façon incomplète.

D'après votre formule initiale, je suppose qu'il faille additionner les valeurs qui sont en colonne F, donc

=SOMMEPROD((JOURSEM($C$1:$C$31;2)>5)*1;($F$1:$F$31))


Cdlt
Messages postés
26
Date d'inscription
vendredi 2 octobre 2009
Statut
Membre
Dernière intervention
9 septembre 2020
1
Génial, ça fonctionne. Merci beaucoup.
Et oui, c'est vrai qu'il faut arriver à donner toutes les informations et surtout les bonnes.
Et encore merci et très bonne journée.

PS: Maintenant il faut que je décortique la formule pour bien la comprendre, car mon but aussi est de m'amélioré en Excel :)