Valeur #N/A en utilisant une combinaison des formules SI et RECHERCHEV [Résolu]

Signaler
Messages postés
118
Date d'inscription
jeudi 26 novembre 2009
Statut
Membre
Dernière intervention
2 juillet 2020
-
Messages postés
118
Date d'inscription
jeudi 26 novembre 2009
Statut
Membre
Dernière intervention
2 juillet 2020
-
Bonjour,


J'ai un tableau avec deux feuilles.
Feuille 1 : les clients de l'année passée avec leurs chiffres d'affaire respectifs.
Feuille 2 : les clients de cette année avec leurs chiffres d'affaire respectifs.

Je souhaite ajouter une colonne dans la feuille 2 me permettant d'un coup d'oeil de voir si le client qui a commandé cette année l'avait aussi fait l'an dernier en indiquant "oui" ou "non".

J'ai essayé une fonction SI combinée à recherchev, avec l'idée suivante : si le client a généré un chiffre d'affaire l'an dernier, la valeur retournée sera "oui", sinon, "non".

Voici la syntaxe:
=SI(RECHERCHEV('Feuil2Client;Feuil1Matrix;2;FAUX); "oui"; "non")

Bien entendu, si le client indiqué sur la feuille 2 n'apparaît pas dans la feuille 1, la formule me renvoit #N/A. Comment modifier la formule afin qu'elle remplace #N/A par "non"?

Ou bien y a-t-il une formule/syntaxe plus adaptée?

Merci d'avance !

Configuration: Windows / Firefox 68.0

4 réponses

Messages postés
1107
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
20 octobre 2020
111
Puisque CCM ne veut pas prendre la modif de mon dernier post :

=SIERREUR(SI(RECHERCHEV(A1;Feuil1!$A$1:$C$200;2;0)<>"";"oui";"non");"non")

en considérant oui et non si le client est en Feuil1 et que oui il a un CA ou non s'il n'en a pas
en considérant que non, si le clien n'apparait pas en Feuil1
Messages postés
118
Date d'inscription
jeudi 26 novembre 2009
Statut
Membre
Dernière intervention
2 juillet 2020
14
Cela fonctionne !!
Messages postés
2472
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
21 octobre 2020
1 270
Bonjour,

Dans le cas ou votre rechercheV fonctionne il doit mettre Oui ou la valeur trouvé?

Essayer avec la formule Sierreur:
=SIERREUR( RECHERCHEV('Feuil2Client;Feuil1Matrix;2;FAUX);"Non")
Messages postés
118
Date d'inscription
jeudi 26 novembre 2009
Statut
Membre
Dernière intervention
2 juillet 2020
14
Il doit mettre "oui"
Messages postés
1107
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
20 octobre 2020
111
Bonjour,

dans ceci :
=SI(RECHERCHEV('Feuil2Client;Feuil1Matrix;2;FAUX); "oui"; "non")

ça ne peut fonctionner !

ce serait plutôt un truc du genre en Feuil2 :
=SI(RECHERCHEV(A1;Feuil1!$A$1:$C$200;2;0)<>"";"oui";"non")

Nom de feuille et plage de cellules à adapter ;)
Messages postés
9579
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
16 octobre 2020
1 926
Bonjour

Une solution avec NB.SI
https://www.cjoint.com/c/JGcj7Fo3ixB

Cdlmnt