Etendre la mise en forme conditionnelle ligne [Résolu]

Signaler
Messages postés
6
Date d'inscription
vendredi 10 juin 2016
Statut
Membre
Dernière intervention
27 juin 2020
-
Messages postés
17139
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 juillet 2020
-
Bonjour,

Je cherche à mettre une mise en forme conditionnelle sur mon tableau en utilisant une formule du type "=SI($G2>$H2;FAUX;VRAI)" que j'insère dans la commande "utiliser une formule pour déterminer pour quelles cellules le format sera appliqué".
Cette formule est valable pour la ligne 2, mais je souhaite qu'en ligne 3 appliquer la formule "=SI($G3>$H3;FAUX;VRAI)", et ainsi que suite pour tout mon tableau. J'ai fait plusieurs tentatives avec le $, mais rien n'y fait, toute la colonne se réfère à "=SI($G2>$H2;FAUX;VRAI)".
Je précise que j'ai converti mes plages de données en tableau.
Merci de votre aide

3 réponses

Messages postés
17139
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 juillet 2020
4 128
bonjour,

dès le départ il fallait sélectionner le tableau et appliquer ta formule.

tu peux reprendre la main en cliquant sur la cellule de la ligne 2 sur laquelle tu as créé ta formule conditionnelle
et Mise en forme conditionnelle/Gérer les règles dans s'applique à tu dois avoir

=$2:$2 ou suivant ton tableau quelque chose comme cela =$A$2:$L$2

il suffit de saisir la première cellule du tableau : dernière cellule du tableau ce qui devrait donner
pour un tableau A2:L50
=$A$2:$L$50
par contre ta formule conditionnelle m'interpelle, que veux tu exactement faire

il me semble que cette formule devrait faire l'affaire
=$G2>$H2 ou le contraire =$G2<$H2

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Messages postés
6
Date d'inscription
vendredi 10 juin 2016
Statut
Membre
Dernière intervention
27 juin 2020
1
J'avais déjà essayé de sélectionner la colonne en question avant d'utiliser la commande mise en forme conditionnelle mais pas de changement...:( Il y a un truc que je fais mal...

En fait, sur la ligne 2, je souhaite appliquer une couleur x si la valeur de la cellule G2 et > à celle de H2, et appliquer une autre autre couleur si cette valeur est <.
Et ainsi de suite sur la ligne 3, etc etc.

J'ai essayé ta formule et nickel, ça marche!!! Merci beaucoup de ton aide.
Messages postés
17139
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 juillet 2020
4 128
Re,

alors commence par supprimer ta ou tes formules conditionnelles de ton tableau

ensuite sélectionne la totalité du tableau exemple A2:M50

Mise en forme conditionnelle, applique cette formule
=$G2>$H2
Format/Remplissage/choisir la couleur
Valide
et recommence avec cette fois cette formule inverse

=$G2<$H2
Format/Remplissage/choisir la couleur
Valide

mais dans une des deux formules il va falloir ajouter un ==

=$G2>=$H2
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...