Nb.si

Signaler
-
Messages postés
51770
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
31 mai 2020
-
Bonjour,
ma fille a un exercice sur excel mais nous sommes coincées....
elle doit trouver dans une colonne toutes les cellules qui ne contiennent pas de nombres avec la formule NB.SI.
Merci de bien vouloir me dire quelle formule doit elle entrer svp



Configuration: Windows / Chrome 80.0.3987.149

4 réponses

Messages postés
16207
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
13 mai 2020
9 403
Bonjour

Elle peut utiliser NB.SI avec comme critère "*". Le * est un caractère générique qui représente du texte. Par exemple pour la plage de cellule A1:A10, la formule sera :

=NB.SI(A1:A10;"*")

m@rina
merci ça marche elle a également des cellules vide dans ce cas que mettre avec =NB.SI(A1:A10; pour trouver le nombre de cellule vide
merci pour votre réponse à tous
Messages postés
25111
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 mai 2020
5 272 > rbk
=NB.SI(champ;"")
Messages postés
1954
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
30 mai 2020
306
Bonjour,
Un exemple de votre fichier avec explications serait le bienvenu.
Pour transmettre un fichier,
Veillez à ce qu'il n'y ait PAS DE DONNEES CONFIDENTIELLES
il faut passer par un site de pièce jointe tel que cjoint.com

Allez sur ce site : https://www.cjoint.com/
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse...
Cordialement



Messages postés
25111
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 mai 2020
5 272
Bonjour
y a t'il des nombres négatifs?
s'il n'y a que des positifs:
=NB.SI(champ;">=0")
si négatif est positif
=NB.SI(champ;">=0")+NB.SI(champ;"<0")
vous donne le nombre de num
donc pour avoir le nombre de texte:
=NBVAL(A1:A20)-NB.SI(A1:A20;">=0")-NB.SI(A1:A20;"<0")

ou plus directement selon les éléments de votre champ:
=SOMMEPROD((ESTTEXTE(champ))*1)


crdlmnt

Messages postés
51770
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
31 mai 2020
13 322
Bonjour rbk.

Tu vois bien qu'avec ta question trop imprécise, tu as des réponses diverses et variées.


- JCB40 t'a pourtant demandé d'envoyer le fichier Excel ; nous attendons toujours ...
- m@rina t'a répondu en pensant que la liste de ta fille ne contenait que des textes et des nombres ...
- Vaucluse a supposé qu'il y avait des textes, des nombres positifs et des nombres négatifs ...
Voila que tu annonces qu'il y a aussi des cellules vides !
Il y aurait-il également des cellules avec des dates, d'autres avec des heures ? Des valeurs nulles ?
Doit-on utiliser uniquement la fonction NB.SI dans la formule, ou peut-on la combiner avec d'autres ?
(Si ta fille n'a pas droit à la fonction NBVAL, elle devra saisir au clavier la taille de la liste !)

On attend avec impatience ta liste et tes précisions !
C'est bien, la retraite ! Surtout aux Antilles ... 
Raymond (INSA, AFPA)