Liaison par date [Fermé]

Signaler
Messages postés
37
Date d'inscription
dimanche 11 novembre 2007
Statut
Membre
Dernière intervention
4 octobre 2019
-
 sisijp -
Bonjour les champions d'Excel,
Je veux qu'apparaisse dans les cellules de la colonne A de ma feuille 1 les textes qui sont dans la colonne 1 des feuilles 2, 3 et 4 en fonction de la date. Feuille 2 si on est en janvier, mai ou septembre, feuille 3 si on est en février, juin ou octobre etc....
J'ai mis une formule "aujourd'hui" dans ma feuille 1.

Voila, j'espère que vous avez suffisamment d'infos. Merci d'avance




Configuration: Windows / Internet Explorer 11.0

4 réponses

Messages postés
11715
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
3 août 2020
671
bonjour, je pense que le plus simple, si tu as peu d'expérience avec excel, est de mettre dans une colonne, disons G, les valeurs extraites de Feuille 2, et dans la colonne H, les valeurs extraites de feuille .
tu pourras ensuite mettre en A une formule allant chercher les valeurs soit en G, soit en H.
Messages postés
37
Date d'inscription
dimanche 11 novembre 2007
Statut
Membre
Dernière intervention
4 octobre 2019
33
Bonjour et merci. mais quelle formule pour que ça aille chercher en G ou H en fonction de la date du jour ?
Messages postés
11715
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
3 août 2020
671
je suggère d'avoir une cellule, disons I1, dans laquelle tu mets un formule qui retourne 0 si il faut chercher dans la colonne G, 1 si il faut chercher dans la colonne H. je suggère d'utiliser les fonctions MOD, MOIS et AUJOURDHUI.
et en A, simplement utiliser une formule avec la fonction SI.
Messages postés
37
Date d'inscription
dimanche 11 novembre 2007
Statut
Membre
Dernière intervention
4 octobre 2019
33
Ha !!!!!
Disons que je veuille remplir la cellule A1, que ma date est en F1(=aujourd'hui ()), le mot "noir" en G1 et le mot "rouge" en H1...Tu pourrais m'écrire la formule stp.

merci
Messages postés
11715
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
3 août 2020
671
je mettrais plutôt en F1:
=MOD(MOIS(AUJOURDHUI());4)

et en A1 (à recopier vers le bas):
=SI($f$1=1;G1;SI($f$1=2;H1;SI($f$1=3;I1;J1)))
OK, j'essaierai demain, merci