Arrondi au 8 inferieur... [Résolu/Fermé]

Signaler
Messages postés
185
Date d'inscription
lundi 15 octobre 2018
Statut
Membre
Dernière intervention
21 juin 2020
-
Messages postés
185
Date d'inscription
lundi 15 octobre 2018
Statut
Membre
Dernière intervention
21 juin 2020
-
Bonjour,

Comment dire ça...

Mes valeurs doivent finir par 8

a1 = 1200
J'aimerais que b1 affiche 1198.

Si a1 = 557, b1=548.

En fait, chercher le nombre entier inférieur terminant par 8...

Une idée avec la fonction arrondi?

Configuration: Android / SamsungBrowser 9.2

3 réponses

Bonjour,

Ou encore
=ARRONDI.INF((A1-8);-1)+8
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 56860 internautes nous ont dit merci ce mois-ci

Messages postés
8161
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
4 août 2020
1 442
Bonjour,

Plus simplement :
=ARRONDI.INF(A1+2;-1)-2
Messages postés
591
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
19 juin 2020
48
je ne connaissais pas l'argument en négatif pour arrondir à la dizaine effectivement c'est plus simple
Messages postés
185
Date d'inscription
lundi 15 octobre 2018
Statut
Membre
Dernière intervention
21 juin 2020
1
Énorme! J'étais en train d'écrire des formules de 6 pages...

Merci infiniment, ça marche parfaitement!
Messages postés
591
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
19 juin 2020
48
Bonjour,

c'est sûrement du bricolage mais ça a le mérite de répondre à la demande..

=SI(DROITE(A1;1)="9";A1-1;SI(DROITE(A1;1)<"8";(ARRONDI.INF(A1/10;0)-1)*10+8;A1))
Messages postés
4854
Date d'inscription
mardi 19 janvier 2010
Statut
Contributeur
Dernière intervention
21 juillet 2020
1 041
Bravo pour le gros bricolage, qui a l'air de marcher parfaitement bien ;-)
Messages postés
591
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
19 juin 2020
48 >
Messages postés
4854
Date d'inscription
mardi 19 janvier 2010
Statut
Contributeur
Dernière intervention
21 juillet 2020

Merci, j'ai pensé à faire une fonction en vba mais ma macro aurait fait exactement le même boulot donc tant que ça passe en formule on se passe de code ^^