Comparaison 1 cellule à 2 plages de cellule et attribuer un texte [Résolu/Fermé]

Signaler
Messages postés
8
Date d'inscription
lundi 18 mars 2019
Statut
Membre
Dernière intervention
19 mars 2019
-
Messages postés
8
Date d'inscription
lundi 18 mars 2019
Statut
Membre
Dernière intervention
19 mars 2019
-
Bonjour à tous,

Je souhaite comparer 2 plages de cellules et attribuer un texte dans une cellule si les 2 plages de cellules sont correspondantes.
J'ai 2 feuillets EXCEL avec différentes données, je dois comparer un listing A avec le listing B si cellule Ax sur feuillet A =cellule Cx sur feuillet B alors attribuer le texte de la cellule Fx feuillet B sur le feuillet A sur la ligne du feuillet A.
Toutes les cellules sont des cellules texte
Un grand merci pour votre aide précieuse !

2 réponses

Messages postés
2875
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
24 novembre 2020
397
Bonjour,

Essaye en adaptant
en feuila!f1
=si(feuila!a1=feuilb!c1;feuilb!f1;"")


Crdlmt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Messages postés
8
Date d'inscription
lundi 18 mars 2019
Statut
Membre
Dernière intervention
19 mars 2019

Bonjour, cela ne fonctionne pas car c'est une plage de données.
Merci
Messages postés
25597
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 novembre 2020
5 617 >
Messages postés
8
Date d'inscription
lundi 18 mars 2019
Statut
Membre
Dernière intervention
19 mars 2019

Messages postés
25597
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 novembre 2020
5 617
Re
Est ce le même sujet que le précédent?
par exemple si on commencer sur ligne 2
en C2 de FeuilA
si les données à comparer sont sur la même ligne dans chacune des feuilles:
=SI(A2=FeuilB!C2;FeuilB!F2;"")

et s'il faut ressortir des valeurs de F si GB contient la valeur de A2 sur n'importe quelle ligne de FeuilB:

=SI(ERREUR(RECHERCHEV(A2;FeuilB:F;5;0);"")

le code SIERREUR ne fonctionne qu'à partir d'Excel 2007 revenez en cas de besoin si ce n'est pas votre cas

crdlmnt



1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Messages postés
2875
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
24 novembre 2020
397
=SIERREUR(RECHERCHEV(G11;'LISTING CLIENT OK'!B2;5;0);"")
Messages postés
25597
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 novembre 2020
5 617
voir en partie la réponse de l'ami DjiDji (salut) qui a corrigé une parenthèse de trop dans ma proposition. Les fautes de frappe, c'est assez ma spécialité. J'y suis meilleur qu'en Excel, en fait!
Mais notre ami DjDji a oublié de spécifier le champ qui contient les cinq colonnes nécessaires à recherche
Donc pas de souci à deux on va y arriver, et en définitif ça donnerait:
=SIERREUR(RECHERCHEV(G11;'LISTING CLIENT OK'!B:F;5;0);"")
crdlpmnt
Messages postés
8
Date d'inscription
lundi 18 mars 2019
Statut
Membre
Dernière intervention
19 mars 2019

Wow genial ! Merci à tous les 2 ! çà fonctionne !!! vous êtes au top !
Messages postés
25597
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 novembre 2020
5 617
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt
Messages postés
8
Date d'inscription
lundi 18 mars 2019
Statut
Membre
Dernière intervention
19 mars 2019

merci de votre réactivité en tout cas