Impossible d’installer net framework 3.5 (inclut 2.0 et 3.0) sur Win10 (système [Fermé]

Signaler
Messages postés
3
Date d'inscription
dimanche 3 mars 2019
Statut
Membre
Dernière intervention
28 avril 2020
-
 El-Chapoune -
Bonjour,

Tout le titre ne rentre pas donc c’est :
« Impossible d’installer net framework 3.5 (inclut 2.0 et 3.0) sur Win10 (système d’exploitation 17134.523) / et mise à jour Windows Update »
Car je pense que le problème de base est du à Windows Update qui échoue en permanence.et m'indique ce message ci :
"Mise à jour cumulative pour Windows 10 Version 1803 pour les systèmes x64 (KB4487017) - Erreur 0x80070002"

J'ai un peu fouillé sur internet, j'ai pu lire ici qu'il fallait aller dans dans le "dossier C: / Windows / SoftwareDistribution / Download" , tout supprimer et télécharger et installer manuellement la dernière mise à jour via ce lien ::
https://?q=KB4487017

Ayant peur de faire une bêtise je n'ai pas supprimer le dossier "download" mais j'ai téléchargé la version qui pèse 810Mo qui correspond à mon message d'erreur et correspond à mon système.x64.

J'ai à nouveau voulu installer "Net Framework" mais je me heurte au même soucis, idem pour Windows Update, donc le téléchargement de 810Mo n'a servit absolument à rien !

En suivant des liens d’aide Windows j'ai pu m'apercevoir ici : https://support.microsoft.com/fr-fr/help/4480966/windows-10-update-kb4480966
que ma version build du système la 17134.523 datait du 8 Janvier 2019 or j'ai acheté mon PC le 30 Janvier 2019, je me demande pourquoi je n'ai pas eu la version 17134.556 qui date du 15 Janvier 2019 ?!
Bref j’ai plusieurs mis à jour de retard et impossible de les faire !

Merci de m"aider car entre Net Framework et Windows Update… je craque !!!

Merci beaucoup

Configuration: iPhone / Safari 12.0

5 réponses

Messages postés
5111
Date d'inscription
vendredi 2 novembre 2018
Statut
Contributeur
Dernière intervention
19 juin 2020
1 355
Bonjour El-Chapoune,

Résolution 0x80070002 : https://support.microsoft.com/fr-fr/help/10164/fix-windows-update-errors

Réparer Windows Update
: https://support.microsoft.com/fr-fr/help/4027322/windows-update-troubleshooter

.NET Framework 4.7.2 : https://dotnet.microsoft.com/download/dotnet-framework/net472

En espérant avoir apporter une solution à ton problème.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 62309 internautes nous ont dit merci ce mois-ci

Impossible d'effectuer l'installation de .NET Framework 4.7.2 car :

.NET Framework ou une mise à jour ultérieure est déjà installé sur cet ordinateur


Suite à ton 1er lien que j'ai suivi à la lettre, tout est rentré dans l'ordre et en voulant lancer le jeu "l'installation de NET Framework 3.5 c'est lancé et installé intégralement" jusqu'au message d'erreur que j'ai obtenu en voulant par la suite lancer le jeu.
Messages postés
5111
Date d'inscription
vendredi 2 novembre 2018
Statut
Contributeur
Dernière intervention
19 juin 2020
1 355 > El-Chapoune
Désinstalle la version 3.5 de .NET Framework pour installer la version la plus récente.
> .NET Framework 4.7.2 : https://dotnet.microsoft.com/download/dotnet-framework/net472

Cela a corrigé le problème ?
Comment désinstaller la version 3.5 de Net Framework ?
salut , a vrai dire je suis pas sur de comprendre pourquoi tu veux à tous prix installer une version obsolète de net framework 3.5
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 62309 internautes nous ont dit merci ce mois-ci

C'est lorsque j'ai voulu lancé un vieux jeu téléchargé sur STEAM que pour jouer j'ai eu le message d'erreur avec .NET Framework 3.5


Puis j'ai eu après le message d'erreurs décrit plus bas...
Messages postés
79962
Date d'inscription
mercredi 27 mai 2009
Statut
Modérateur
Dernière intervention
9 juillet 2020
11 123
Bonjour,

Si tu souhaites de passer à la dernière version, soit la 1809:
Télécharge ceci -->> MediaCreationTool1809 <<--
Lance-le
Coche --> Mettre à niveau ce PC maintenant

Windows Update est rentré dans l'ordre. MediaCreationTool1809 c'est pour NET Framework ou Windows Update ?
Messages postés
5111
Date d'inscription
vendredi 2 novembre 2018
Statut
Contributeur
Dernière intervention
19 juin 2020
1 355 > El-Chapoune
MediaCreationTool1809 sert à mettre ta machine à la dernière version de Windows soit la 1809.

Pour vérifier la version de Windows :

Maintiens les touches : Windows + R
Recherche : winver
Version 1803 version du système d'exploitation (17134.590)
Messages postés
5111
Date d'inscription
vendredi 2 novembre 2018
Statut
Contributeur
Dernière intervention
19 juin 2020
1 355 > El-Chapoune
Comme l'a dit Kaneagle, tu peux passer à la dernière version de Windows avec MediaCreactionTool.

ICI : https://software-download.microsoft.com/download/pr/MediaCreationTool1809.exe
Comment se fait il que je ne sois pas à la dernière version alors Windows Update est rentré dans l'ordre et ne m'indique pas de nouvelle mise à jour ?
Ok merci pour vos retours.

J'ai cliqué sur le 1er lien de "ChariduP" et suivit la démarche, ça m'a orienté vers un téléchargement d'un diagnostic de Windows Update, qui redémarrage à tout remis dans l'ordre :
- Windows Update comme Framework….


Seulement lorsque j'ai voulu lancer le jeu (suite à l'installation de Framework), j'ai eu un nouveau message d'erreur :

[Microsoft .NET Framework
Une exception non gérée s'est produite dans votre application. Si vous cliquez sur Continuer, l'application va ignorer cette erreur et essayer de continuer. Si vous cliquer sur Quitter, l'application va s'arrêter immédiatement.
Un composant externe a levé une exception]

si je clique sur "Détails" j'ai cela :

[Consultez la fin de ce message pour plus de détails sur l'appel du débogage juste-à-temps (JIT) à la place de cette boîte de dialogue.]

(Tout à la fin voici le message) :
[***************** Débogage JIT ********************
Pour activer le débogage (JIT), le fichier de configuration pour cette application ou cet ordinateur (machine config) doit avoir la valeur jit.Debugging définie dans la cestion system.windows.forms. L'application doit également être completée avec le débogage activé.

Par exemple :

<configuration>
<system.windows.forms jit.Debugging="true" />
</configuration>

Lorsque le débogage juste-à-temps est activé, les exceptions non gérées seront envoyées au débogeur JIT inscrit sur l'ordianteur pluôt que d'être gérées par cette boîte de dialogue.]


Voilà, donc je nage encore plus là !
Messages postés
5111
Date d'inscription
vendredi 2 novembre 2018
Statut
Contributeur
Dernière intervention
19 juin 2020
1 355
heu, je suis pas ingénieur lol c'est assez lourd comme démarche
Bon la version de Windows n'interfère en rien, cela vient surtout du jeu que je souhaite installer "Batman Arkham Asylum" qui a beaucoup de bug au démarrage visiblement.
J'ai eu besoin de PhysX pour cela, je l'ai donc installé.

Désormais message d'erreur est différent, toujours Microsoft .NET Framework, qui écrit "une exception non générée….immédiatement.

Mais cette dois ci un message différent en dessous (juste au dessus de l'onglet "détails" :

[Impossible de charger le ou l'assembly '<Microsoft.DirectX.Direct3D.
Version=1.0.2902.0.Culture=neutral.
PublicKeyToken=31bf3856ad364e35' ou une de ses dépendances. Le ficher spécifié est introuvable.]

Sur YouTube il y a une personne qui poste ce tutto pour le problème que je rencontrais précédement :

https://www.youtube.com/watch?v=Ma5MOex4u6M

Entre 5"59min et 6"03min l'on peut voir qu'il choisi la version de Windows or la version Windows 10 n'apparait pas !

Je me demande s'il est donc bien sur Windows 10 car le jeu était à la base pour Windows 7 et 8

Sur STEAM il y a la possibilité de vérifié l'intégrité des fichiers téléchargés comme expliqué dans la vidéo, ils le sont tous sans exception.

Merci beaucoup de m'aider, j'aimerai enfin pouvoir jouer à ce jeu