RechercheV dans un onglet spécifique [Résolu/Fermé]

Signaler
-
Messages postés
17134
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
4 juillet 2020
-
Bonjour,
J'ai un classeur Excel avec 3 onglets

1onglet nommé "Jacques" avec le mot "Taille" en A1 et "1m80" en B1
1onglet nommé "Laura" avec le mot "Taille" en A1 et "1m60" en B1

1onglet nommé "Matrice", qui servira à faire afficher les critères recherchés
dans la cellule A1, je veux saisir un nom (Dans cet exemple, saisie de Jacques)
dans la cellule A2, le mot "Taille" (critère de recherche)
dans la cellule B2, le résultat recherché (dans l'exemple 1m80).

La fonction doit donc tenir compte du nom qui figure dans l'onglet matrice, pour rechercher le résultat dans l'onglet qui porte le même nom...

Merci d'avance pour vos suggestions.
Guy

6 réponses

Messages postés
17134
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
4 juillet 2020
4 116
Bonjour,

difficile de comprendre, Le mieux est de créer un exemple de fichier anonymisé et le joindre à la discussion afin que l'on puisse te guider
pour joindre ton fichier
1) Tu vas dans https://www.cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers

dans le même style tu as https://mon-partage.fr/
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63959 internautes nous ont dit merci ce mois-ci

Messages postés
418
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
21 mai 2019
61
Bonjour,
Essayez ça en B2 :
=RECHERCHEV(A2;INDIRECT(A1&"!A:B");2;0)
Si il y a des espaces dans les noms de feuilles :
=RECHERCHEV(A2;INDIRECT("'"&A1&"'!A:B");2;0)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63959 internautes nous ont dit merci ce mois-ci

Bonjour Mike,
Lien ci-dessous, pour exemple de fichier.
La fonction est à coller dans la cellule B1 de l'onglet Matrice.
Elle doit rechercher, en fonction du prénom dans la cellule A1 , la taille correspondante figurant dans l'onglet du prénom concerné.
Dans l'exemple, le résultat recherché est 1m80.

https://www.cjoint.com/c/HKBqgbsslOG

Merci d'avance
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63959 internautes nous ont dit merci ce mois-ci

Messages postés
418
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
21 mai 2019
61
Je confirme que la formule suivante fonctionne dans votre cas :
en B2 :=RECHERCHEV(A2;INDIRECT(A1&"!A:B");2;0)
Messages postés
17134
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
4 juillet 2020
4 116
Re,

Une discussion est un lieu de partage et d'échange et avant de voir ton fichier j'avais songé à la fonction INDIRECT que t'a proposé didibonf que je salue et sans l'avoir testée me semble la plus appropriée
Merci didibonf, ç'est nickel !!!
Mike_31, effectivement, ce forum est un lieu de partage et franchement, votre réactivité, à toi & didibonf, ainsi que vos connaissances sont très appréciables !
Merci à vous.
Guy
Messages postés
17134
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
4 juillet 2020
4 116
Re,

si tes attentes sont satisfaites, je passe le statut de la discussion en résolu