Somme.si cellules commencant par le meme nom [Résolu/Fermé]

Signaler
Messages postés
7
Date d'inscription
jeudi 27 septembre 2018
Statut
Membre
Dernière intervention
5 octobre 2018
-
Messages postés
25248
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 août 2020
-
Bonjour,

Je vais essayer d'expliquer clairement ma recherche :

J 'ai un tableur comprenant un extrait de grand livre comptable dans un onglet appele"GL" avec des comptes et des sous comptes :
par exemple :
A B C
compte 625 transport 300 €
compte 62501 transport personnel 400 €
compte 62502 transport administrateur 500 €

Dans un autre onglet "Resultat", j'ai un tableau reprenant que les comptes généraux a 3 chiffres et les montants.
Est ce que quel qu'un saurait comment additionner dans ma cellule de l'onglet resultat tous les comptes commencant par 625 se situant dans l'onglet "GL".

Merci par avance pour vos lumieres qui me sauveraient !

3 réponses

Messages postés
25248
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 août 2020
5 432
Bonjour

=SOMME.SI(GL!A:A;"compte 625*";GL!C:C)

ou encore:
=SOMME.SI(GL!A:A;"*625*";>GL!C:C)

et si le 625 est dans une cellule, par exemple en A2 de la feuille de résultat:
=SOMME.SI(GL!A:A;"*"'&A2&"*";GL!C:C)


attention à tous les signes, y compris la ou les astérisques
crdlmnt


Messages postés
7
Date d'inscription
jeudi 27 septembre 2018
Statut
Membre
Dernière intervention
5 octobre 2018

wahou ! C'est ultra rapide !
Merci, j'essaie de suite !
Messages postés
7
Date d'inscription
jeudi 27 septembre 2018
Statut
Membre
Dernière intervention
5 octobre 2018

il ne trouve pas de résultat, alors que dans GL j'ai 53 lignes commençant par ces 3 chiffres.
J'ai essayé la deuxieme formule.... Est parce qu'il ne compterait que les comptes correspondant a 625 et ne commencant pas par 625 ?
Messages postés
7
Date d'inscription
jeudi 27 septembre 2018
Statut
Membre
Dernière intervention
5 octobre 2018

idem avec la première formule....
Messages postés
25248
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 août 2020
5 432
cette formule tout compter toutes ls lignes qui contiennent 625, si vous avez bien placé les astérisques de chaque cotés; q'il soit à la fin ou au début du texte dans la cellule
. Pouvez vous déposer un exemple de modèle ici:
http://mon-partage.fr
et revenir coller le lien créé sur le site
qu'on voir ce qui coince
à vous lire ... je reviens dans une heure
en attendant essayez cette formule en feuille GL et voyez si elle renvoie bien 53:

=NB.SI(A:A;"*625*")
Messages postés
7
Date d'inscription
jeudi 27 septembre 2018
Statut
Membre
Dernière intervention
5 octobre 2018

Alors il doit y avoir un probleme dans mon fichier GL car il me renvoie 0 resultat avec cette formule
Messages postés
7
Date d'inscription
jeudi 27 septembre 2018
Statut
Membre
Dernière intervention
5 octobre 2018

Bonjour,
Voici le lien du fichier : https://mon-partage.fr/f/Oi3xHUTn/
Et merci encore pour votre aide !
C'est le compte commence par 604 qui a 53 résultats
Messages postés
25248
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 août 2020
5 432
Bonjour
votre fichier doit avoir un "passé" de copier coller qui fait que Excel conserve le type numérique même avec des cellules en format texte.
et la formule proposée ne fonctionne qu'avec du texte
Il semble que ce soit le cas de votre colonne A
voyez dans le fichier joint la manip qui permet d'appliquer la formule, décrite ci dessous:
  • création de la colonne G pour garantir la transformations de la valeur en texte
  • (vous pouvez aussi sur G utilisez la formule: =GAUCHE(A3;NBCAR(A3))
  • copie de la colonne G
  • collage spécial "valeur seulement" sur la colonne A

et là, au moins chez moi, la formule fonctionne dans la feuille résultat
https://mon-partage.fr/f/6AkhmXjc/

revenez si problème

crdlmnt


Messages postés
7
Date d'inscription
jeudi 27 septembre 2018
Statut
Membre
Dernière intervention
5 octobre 2018

Merci beaucoup pour la solution ! C'est impeccable ! Vous êtes un génie !
Messages postés
25248
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 août 2020
5 432
n’exagérons rien, il s'en faut de beaucoup!
bonne route
crdlmnt