Si la cellule commence par. ou bien par.. [Résolu/Fermé]

Signaler
-
Messages postés
53307
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 février 2021
-
Bonjour,

je souhaiterais sur excel 2003 connnaitre la fonction
SI la cellule commence par X ou bien par Y ou bien par Z, ALORS... SINON rien

J'ai la fonction SI(STXT(A1;1;3)="abc";d;"")
mais je ne sais pas comment intéger le OU, par exemple : si la cellule par abc, def ou ghi.

merci à tous!! :-))

A voir également:

2 réponses

Messages postés
25817
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 février 2021
5 784
Bonjour
=SI(GAUCHE(A1;1)="X";résultat;"")

si toutes les lettres codées doivent donner le même résultat:
=SI(OU(GAUCHE(A1;1)="X";GAUCHE(A1;1)="Z";....;....);résultat;"")

Crdlmnt





8
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

merci bcp d'avoir répondu aussi vite, j'essaie tt de suite!!
Messages postés
53307
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 février 2021
15 331
Bonjour loeh.

Pour reprendre exactement ta formule
=SI(STXT(A1;1;3)="abc";d;"") 

je te propose
=SI(<bold>OU(STXT(A1;1;3)="abc";STXT(A1;1;3)="def";STXT(A1;1;3)="ghi")</bold>;d;"")


Cordialement.
C'est bien, la retraite ! Surtout aux Antilles ... :-)
☻ Raymond ♂