Récupérer des données d'un tableau vers un autre [Résolu/Fermé]

Signaler
Messages postés
7
Date d'inscription
dimanche 2 octobre 2016
Statut
Membre
Dernière intervention
25 septembre 2018
-
Messages postés
25366
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
-
Bonjour à tous,

Je vous sollicite car j'ai besoin d'aide.

J'aimerais récupérer certaines données du Tableau 1 pour les ajouter au Tableau 2.

Dans le tableau 1 : j'ai une colonne "identité" et une colonne "niveau"

Dans le tableau 2 : j'ai une colonne "identité" sans le prix mais avec le total des coûts de salaire, de formation etc...


Je ne peux pas faire de copier coller car toutes les salariés du T1 ne sont pas présents dans le T2 et les tableaux sont vraiment trop longs pour faire ligne par ligne.


Ainsi, je cherche une formule qui me permet de récupérer le niveau de chaque salarié que si elles existent dans le 2ème tableau.

ex : Si identité "dupont' existe dans le Tableau 1 et dans le Tableau 2, alors mettre le niveau indiqué du tableau 1 dans le Tableau 2.

J'espère avoir été clair.

Merci a tous pour votre aide.

1 réponse

Messages postés
25366
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
5 521
Bonjour
selon la disposition de votre tableau 1les formules peuvent être différentes

si vous avez l'identité en A et le niveau en B dans la feuil1 et la liste de noms en A dans la Feruil2
.
dans la colonne feuil2 où vous voulez ressortir le niveau:
(à partir de ligne 2)

=SIERREUR(RECHERCHEV(A2;RECHERCHEV(Feuil1!A:B;0);"")


si toutefois vos colonne tableau 1 sont inversées:

=SIERREUR(INDEX(Feuil1!col.niveau;EQUIV(A2;Feuil1!col.nom;0));"")

notez que le code SIERREUR ne fonctionne qu'à partir d'Excel 2007. Il évite un affichage d'erreur si le nom n'existe pas dans la liste
Si vous êtes sur un plus ancien:

=SI(NB.SI(Feuil1!A:A;A2)=0;"";RECHERCHEV(A2;RECHERCHEV(Feuil1!A:B;0))

et idem avec INDEX

crdlmnt
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
7
Date d'inscription
dimanche 2 octobre 2016
Statut
Membre
Dernière intervention
25 septembre 2018

Bonjour et merci pour votre retour rapide.

J'ai oublié de le préciser mais les feuilles ne sont pas dans le même fichier Excel.
Est-ce que cela va me poser problème avec votre formule ?
Messages postés
25366
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
5 521
Non... il suffit de bien composer les adresses et le mieux pour ça, c'est de les écrire en sélectionnant les champs dans le fichier concerné.

Petit tuyau pour la clarté des écritures:
utilisez cette sélection uniquement pour le fichier externe, il n'est pas utile décrire autre chose que l'adresse de cellule dans le fichier où se trouve la formule)

et notez aussi que pour que les mises à jour fonctionnent en continu, il faut que le fichier source soit ouvert en même temps que le récepteur

crdlmnt