Virtualbox et le mode reseau privé hôte [Fermé]

Signaler
-
Messages postés
92906
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
5 août 2020
-
Bonjour,
je viens vers vous en espoir d'avoir une solution à mes problèmes avec VirtualBox.En effet j'ai la version 5.0.10 r104061 de VirtualBox sur laquelle je crée deux MV.j'ai installé sur l'une un Debian9(Debian-9.3.0-i386-xfce) et sur l'autre TrixBox 2.0.8.4 CE,puis je les ai ensuite en reseau avec le mode Reseau Privé Hôte.
la carte virtual host only a comme IP:192.168.56.2/24
le serveur DHCP de VirtualBox a comme IP:192.168.56.100/24
mes VM je les ai mis en client DHCP, lorsque je demarre toute mon infrastructure voici le sens de fonctionnement des communications:
VM-VM :ok
Hôte-toutes les VM:ok,j'arrive même à me connecté la page web d'administration de TRIXBOX!
VM-Hôte:impossible.lorsque je fais un ping des VM vers l'hôte ca ne passe pas.

j'ai beau essayé durant des heures,j'ai sur les forums des problèmes simillaires toujours aucune solution.j'ai même changé le type de carte reseau toujours rien. c'est je viens chercher de l'aide ici!
SVP aidez moi!!!!



3 réponses

Messages postés
10746
Date d'inscription
lundi 28 octobre 2013
Statut
Contributeur
Dernière intervention
15 juillet 2020
1 679
Bonjour

Votre hote fonctionne avec quel OS ?

La version actuelle est 5.2

Avez-vous essayé de désactiver le pare-feu sur l'hote ?
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 56881 internautes nous ont dit merci ce mois-ci

Messages postés
92906
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
5 août 2020
10 131
Salut,
en effet, ça ressemble à un parefeu qui bloque les ping sur l'hôte.
je n'ai pas bien compris, ton réseau est de type privé ou host only, ça n'est pas pareil.
Dans le second cas, il faut que le l'hôte sache router entre ses réseaux.
Dans le premier cas, les VM peuvent être dans le même réseau IP.

En effet j'ai windows 8.1 sur mon hôte.le type de reseau que j'ai choisi est du type "reseau privé hôte"je pense que c'est l'équivalent francais de l'anglais virtual host only car l'adaptateur virtuel Virtuel Host only Ethernet Adaptor apparait dans la liste "nom" des cartes reseau. En ce qui concerne le pare-feu laissez moi verifier et je vous dis quoi après.en tentant toujours de resoudre ce problème je remarqué que lorsque je me connecte à mon reseau WIFI avec mon hôte les communications commencent à passer.mais foi que je deconnecte de mon WIFI le problème réapparait.
vraiment je ne sais pas quoi faire,aidez moi SVP!!!!
Messages postés
92906
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
5 août 2020
10 131 > franck
Mets tes machines en réseau interne plutôt que réseau privé hôte, si tu veux qu'elles communiquent.
Avec ton wifi, je ne vois pas le rapport, sauf que le parefeu n'est peut-etre pas configuré pareil sur les deux.
Tu veux faire communiquer qui avec qui en fait ?
je veux que mes deux VM communiquent avec mon hôte sans avoir besoin d'une connexion internet.j'ai verifié sur mes deux VM avec iptables -L toutes les policy sont en ACCEPT.du côté hôte donc WINDOWS 8.1 je n'ai trouvé grande chose à faire. Mais je pense qu'avec le mode reseau interne je dois avoir besoin d'une carte physique non?? c'est cette pensée qui m'a poussé à choisir le mode reseau privé hôte,d'accord j'essaie d'abord avec le reseau interne que tu m'a conseillé puis je te fais part des resultats.

merci infiniment pour l'interet que tu accorde à mon post!!!!!
Messages postés
92906
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
5 août 2020
10 131 > franck
Le mode réseau host doit convenir.
pas besoin de carte physique pour le mode réseau interne, mais le host est isolé des machines, sauf s'il fournit le dhcp éventuellement.
encore une fois, vérifie le parefeu de l'hôte pas des VM...
SVP quelqu'un peux m'aidez!!!!!!!??????