Alea entre bornes avec exclusions et sans doublons [Résolu/Fermé]

Signaler
Messages postés
13
Date d'inscription
mercredi 11 mars 2015
Statut
Membre
Dernière intervention
5 mars 2019
-
Messages postés
25467
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
-
Bonjour à tous,

Maintenant plusieurs heures que je cherche sur internet et essaye de bidouiller avec des formules mais sans résultat...

Je vous explique mon problème : J'aimerai sélectionner aléatoirement 175 jours ( dates) en 2017, en excluant certaines dates contenues dans une plage valeurs ( les vacances, les week end ect que j'ai saisi manuellement ) . Et difficultés supplémentaire je ne veux pas qu'il y ai de doublons...

J'aimerai avoir ce résultat sous forme d'une liste de 175 dates.

Merci de votre aide !!




1 réponse

Messages postés
25467
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
5 566
Bonjour
peut être une solution comme ceci:
votre liste de date complète de 2017 en A à partir
votre liste de date à éliminer en Z1:Z50 pour l'exemple, inutile d'inclure les samedi et dimanches

en B en ligne, la formule:

=SI(OU(JOURSEM(A1;2)>5;NB.SI($Z$1:$Z$50;A1));"";ALEA())

en C cette formule à tirer sur les 175 lignes:

=INDEX(A:A;EQUIV(GRANDE.VALEUR(B:B;LIGNE(A1));B:B;0))


bien sur la liste change à chaque action dans la feuille avec le code ALEA

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
13
Date d'inscription
mercredi 11 mars 2015
Statut
Membre
Dernière intervention
5 mars 2019

Super Merci BEAUCOUP! Vous venez de sauver ma soirée !
Messages postés
25467
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
5 566
Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt