Compter les doublons en fonction d'un critères

[Résolu/Fermé]
Signaler
-
 Serocelot -
Bonjour,

Après moult recherches et pas mal d'essai, je ne trouve toujours pas de réponses à ma question...

J'ai un tableau comprenant
Colonne A Colonne B Colonne C
Livreur Client Types de livraison

AG DUPONT TV
FD LENOIR AUDIO
GF DUPONT TV
YT MOUTARDE AUDIO
AG DUPONT CAMERA

Je voudrais trouver une formule qui me permette de savoir que j'ai eu
1 TV (parce que même client)
2 AUDIO
1 CAMERA

Il faudrait que lorsque j'ai le même client avec les deux mêmes types de livraisons, on ne prenne en compte qu'une seule fois le client.

Merci beaucoup beaucoup de votre aide

2 réponses

Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 689
Bonjour,

En D2 :
=NB.SI.ENS($B$2:$B$6;$B2;$C$2:$C$6;$C2)
à tirer jusqu'en D6
Merci beaucoup pour votre aide mais il me faudrait directement le total !
Je vous mets le lien vers un fichier construit de la même façon, cela certainement plus clair !
http://www.cjoint.com/c/GGrnvMGXIx5
Messages postés
13094
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
29 août 2021
2 239 > Serocelot
Re,

Ton fichier avec la formule matricielle en colonne L :
http://www.cjoint.com/c/GGrn0ni3gB6

Cdlmnt
Via
Merci beaucoup !
Messages postés
13094
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
29 août 2021
2 239
Bonjour,

Ce serait plutôt, avec en E2,E3 et E4 les valeurs TV,AUDIO et CAMERA, en F2 la formule matricielle (à valider par CTRL+Maj+Entrée) :
=NB(1/FREQUENCE(SI(($C$2:$C$7=E2);EQUIV($A$2:$A$7;$A$2:$A$7;0));LIGNE(INDIRECT("1:"&LIGNES($A$2:$A$7)))))
A étirer ensuite vers le bas

Cdlmnt
Via

"L'imagination est plus importante que le savoir."    A. Einstein