Compter le nombre de doublons

[Fermé]
Signaler
-
Messages postés
54531
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 septembre 2021
-
Bonjour,

Alors voilà, j'ai utilisé la MFC doublons afin de me repérer tous les doublons dans la colonne B.
S'il y en a, il me les colories en rouge sinon ils restent inchangés.

Mon problème est que je veux compter ce valeur, mais je ne sais pas comment utiliser la fonction (s'il y en a une) des doublons dans une formule.

J'ai commencé un truc mais il manque la fonction, quelqu'un serait-il compléter ?

=NB.SI(B2:B1048576;..............)/2


merci

cordialement

Cédric

2 réponses

Messages postés
54531
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 septembre 2021
16 463
Bonjour Cédric.

Non, à ma connaissance il n'y a ni fonction, ni formule pour ça ...

Mais tu peux :
- soit écrire une macro, si toi tu t'y connais en VBA,
- soit faire une copie de ta colonne dans une autre feuille et lui appliquer l'outil DONNÉES/Supprimer les doublons : une fenêtre t'indiquera le nombre de suppressions et de données uniques.
Messages postés
13094
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
29 août 2021
2 239
Bonjour Cédric, coucou amical Raymond

Je pense qu'une formule de ce style doit pouvoir compter les doublons :
=SOMMEPROD((A2:A1000)/A2:A1000*(NB.SI(A2:A1000;A2:A1000)>1))/2

A tester sur ton fichier

Cdlmnt
Via

"L'imagination est plus importante que le savoir."    A. Einstein
Messages postés
54531
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 septembre 2021
16 463
Salut, via55.

Pour ne pas mourir idiot, je te serais redevable si tu m'explicitais le fonctionnement de ta formule.
En particulier je ne sais pas à quoi sert
/

Mais l'ensemble de la logique de la formule, de toutes façons, m'échappe.

Je t'en remercie d'avance.
>
Messages postés
54531
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 septembre 2021

Bonjour Raymond,
Mais si, tu sais que « / » (slash) est pour diviser :
1er « / » : pour diviser par A2 ; 2ème « / » : pour diviser par 2.
Je laisse à via55 le soin de t'expliquer la suite...
Cordialement
Messages postés
13094
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
29 août 2021
2 239 >
Messages postés
54531
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 septembre 2021

Re Raymond,

Je ne la comprend pas trop bien moi même, je l'ai adapté d'une autre formule mais je m'aperçois qu'elle ne fonctionne pas bien
Je propose celle-ci à la place :
=NBVAL(A2:A1000-SOMMEPROD(1/NB.SI(A2:A1000;A2:A1000))

où SOMMEPROD(1/NB.SI(A2:A1000;A2:A1000)) donne le nombre d'occurences différentes (formule de Jacques Boisgontier, voir sur son site)
donc en soustrayant ce résultat du nombre de valeurs dans la plage donné par le NBVAL on a le nombre de doublons

Cdlmnt
Via
Messages postés
54531
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 septembre 2021
16 463 >
Messages postés
13094
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
29 août 2021

Je te remercie sincèrement, Via.
Je vais effectivement retourner à la "bible" de J.B.
Bonne nuit.