Si valeur dans colonne A afficher contenu même ligne col B

Résolu/Fermé
Fab - 15 déc. 2017 à 12:27
 Fab - 18 déc. 2017 à 12:27
Bonjour,

Je suis confronté à la situation suivante sous excel 2013.
Grâce à la formule grande valeur j'ai extrait un nombre d'une colonne A que je possède donc dans une cellule D1. Cette cellule D1 affiche le nombre de la cellule A8 par exemple.
Dans la cellule E1 je voudrai faire apparaitre le texte qui est dans la colonne B sur la même ligne que la grande valeur, soit le contenu la cellule B8.

Bien sur lors de incrémentation future de ma base de donnée la grande valeur obtenu en D1 évoluera et il ne faut donc pas que je travaille sur la cellule A8 ou B8 mais que cela soit dynamique.

Pensez-vous que cela soit possible ? J'espère que là encore, quelqu'un d'entre vous saura m'aider : -)

Merci.

A voir également:

3 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 272
15 déc. 2017 à 12:36
Bonjour

essayez avec:

=RECHERCHEV(D1;A:B;2;0)

ou directement:

=RECHERCHEV(GRANDE.VALEUR(A:A;1);A:B;2;0)

notez que si votre grande valeur est représentée plusieurs fois en A, vous ne ressortirez que la 1° donnée trouvée en B


crdlmnt
1
Bonjour,
merci pour votre aide. Je viens de tester ces options mais ça bloque. Dans le premier cas j'obtiens #N/A dans le second #NOMBRE!

Je ne sais pas si c'est que je l'ai mal appliqué mais j'essaye de réexpliqué ma situation différemment (je ne sais pas comment mettre un excel en partage) pour nous assurer que nous nous comprenons bien.

Colonne A:
A1 = 12
A2 = 8
A3 = 9
etc...

Colonne B
Pour A1=12, B1=oiseau
Pour A2=8, B1=renard
Pour A3=9, B1=chevreuil
Pour Ax ... Bx= etc....

Dans une cellule j'affiche:
D1 : Grande Valeur rang 1 (rechercher dans colonne A)=12
D2 : Grande Valeur rang 2 (rechercher dans colonne A)=9

Je souhaiterai dans d'autres cellules E trouver:
E1: oiseau
E2: Chevreuil

En espérant que cela vous aide à m'aider :-). Merci
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 272
15 déc. 2017 à 17:11
pourtant ça devrait fonctionner, voyez ici:

https://mon-partage.fr/f/tdhrxUFc/

toutefois, vérifiez que vos données en A sont bien numériques
(sélection de la colonne / format de cellule / alignement / horizontal et "standard"
les valeurs doivent se placer à droite dans la cellule
si ce n'est pas le cas:
copier une cellule vide
sélectionnez colonne A clic droit et collage spécial "ajouter"

et si ça ne va toujours pas, vérifiez qu'il n' y ait pas de blanc devant ou derrière les valeurs
dans ce cas sélectionner A / touche ctrl et touche h
remplacer: taper un blanc
par: ne mettez rien
et "remplacez tout"
(et ensuite faire l'opération précédente)
et si ça ne va toujours pas, il faudra déposer votre fichier via le site où vous avez trouvé le mien

crdlmnt
0
yclik
Messages postés
2966
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
19 septembre 2022
1 357
15 déc. 2017 à 17:11
bonsoir
en Colonne "C" pour traiter les égalités

=A1+LIGNE()/100000


en E
=INDIRECT("B"&EQUIV(GRANDE.VALEUR($C$1:$C$4;LIGNE());$C$1:$C$4;0))

avec à la place de $C$4 le N° de la dernière ligne des données

GRANDE.VALEUR($C$1:$C$4;LIGNE() pour obtenir la nème des grandes valeurs avec ligne()

EQUIV pour avoir le N° de ligne où se trouve la donnée

INDIRECT pour avoir la donnée de la colonne B
0
Bonjour Vaucluse et yclik,

Merci pour vos 2 réponses. J'ai réussi à faire fonctionner vos 2 solutions dans le cas exact que je vous ai proposé.

Je n'ai pas pu l'appliqué en l'état dans ma feuille pour la raison suivante. En fait j'étais coincé par rechercheV (et semble-t-il la fonction INDIRECT dans la seconde solution que vous m'avez proposé) car il faut pour qu'elles fonctionnent que la valeur recherchée soit le plus à gauche de la plage de recherche.

""""
Important : Avec RECHERCHEV, la colonne contenant la valeur ou la référence de cellule que vous recherchez doit être la colonne la plus à gauche de la plage.
https://support.office.com/fr-fr/article/Rechercher-des-valeurs-au-moyen-de-la-fonction-RECHERCHEV-d-INDEX-ou-EQUIV-7144ef3f-e322-4f95-9e96-f1d743270438
"""""
C'était bien le cas dans mon exemple ci-dessus mais pas dans ma feuille de calcul qui est plus complexe et organisé différemment (colonne A et B inversée).

J'ai du coup utilisé une imbrication de la fonction Index et Equiv pour m'en sortir (c'est ce qui était conseillé dans le cas ou RechercheV n'était pas applicable).

=INDEX($A$1:$A$4;EQUIV(D1;$B$1:$B$4;0);1)
"
https://www.excel-pratique.com/fr/fonctions/index_equiv.php
"

(merci à Yclic pour l'astuce de l'ajout de décimales qui m'a permis de gérer les Grandes valeurs de rang différents mais de valeurs égales).

Volià, je ne sais pas si c'est clair mais j'espère que ça pourra en aider d'autres. En tout cas c'est tout bon pour moi.

Merci encore.
0