EXCEL2013 Nombre trop grand d'arguments

[Résolu/Fermé]
Signaler
Messages postés
18
Date d'inscription
mardi 18 juillet 2017
Statut
Membre
Dernière intervention
26 août 2017
-
 steve -
Bonjour,

Moyen de contourner un nombre d'arguments trop grand sans macros ?

=SI(ET(C23=1;C30=1);C3;SI(D10=0;SI(EST.PAIR(D11);D11/2;(D11-1)/2));SI(EST.PAIR(H10);H10/2;(H10-1)/2))

2 réponses

Messages postés
10107
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
14 septembre 2021
2 199
Bonjour

Peut être comme ceci en indentant les si... pour vérifier les parenthèses
=SI(ET(C23=1;C30=1)
;C3
;SI(D10=0
;SI(EST.PAIR(D11)
;D11/2
;(D11-1)/2)
;SI(EST.PAIR(H10)
;H10/2
;(H10-1)/2))

=SI(ET(C23=1;C30=1);C3;SI(D10=0;SI(EST.PAIR(D11);D11/2;(D11-1)/2);SI(EST.PAIR(H10);H10/2;(H10-1)/2)))

Cdlmnt
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42584 internautes nous ont dit merci ce mois-ci

Messages postés
18
Date d'inscription
mardi 18 juillet 2017
Statut
Membre
Dernière intervention
26 août 2017

Eh bien merci beaucoup ça marche !
J'ai pas vraiment compris comment tu avais fait mais merci !
Messages postés
10107
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
14 septembre 2021
2 199
Tu avais une parenthèse fermante en trop ici (D11-1)/2))
et il en manquait une (toujours fermante) à la fin

Bonne soirée
Bonjour Rémi,

Je m'étais trompé dans 2 signes, désolé !

Voici la formule corrigée (à mettre sur une seule ligne) :

=SI(ET(C23=1;C30=1);C3;SI(D10=0;(D11-EST.IMPAIR(D11))/2;
(H10-EST.IMPAIR(H10))/2))

Tu pourras facilement voir que cette formule est bien plus courte
que celle de départ, et donne cette fois les bons résultats.  :)

Cordialement