PMB problème lors de la création base de données

Résolu
Bonjour à tous !

Lors de la création de ma base de données je reçois ce message au moment de la créer :

Notice: Undefined index: data_test in C:\xampp\htdocs\pmb\tables\install_rep.php on line 243
lang = fr charset = iso-8859-1
user = bibli; password = bibli; dbhost = localhost; dbname = bibli
usersystem = root; passwordsystem = ; dbhost = localhost; dbnamesystem =

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in C:\xampp\htdocs\pmb\includes\mysql_functions.inc.php:35 Stack trace: #0 C:\xampp\htdocs\pmb\tables\install_rep.php(259): pmb_mysql_connect('localhost', 'root', '') #1 {main} thrown in C:\xampp\htdocs\pmb\includes\mysql_functions.inc.php on line 35

Je tiens à préciser que Apache et MySQL fonctionnent.
Merci par avance pour votre aide !

6 réponses

  1. Modérateur
    Bonjour,

    Qu'as tu à la ligne 243 du fichier C:\xampp\htdocs\pmb\tables\install_rep.php ?

    Qu'as tu à la ligne 35 du fichier C:\xampp\htdocs\pmb\includes\mysql_functions.inc.php ?

    NB : En ce qui concerne le second message ... il est certainement lié à ta version de php.
    L'extension mysql était obsolète en PHP 5.5.0, et a été supprimée en PHP 7.0.0.
    https://www.commentcamarche.net/faq/43261-php-l-extension-mysql-est-obsolete#top

    À la place, tu peux (enfin non.. tu DOIS ) utiliser l'extension MySQLi ou l'extension PDO_MySQL
    https://www.commentcamarche.net/faq/44117-connexion-a-une-base-avec-pdo-mysqli

    Si tu choisis PDO, pense à activer la gestion des erreurs : https://forums.commentcamarche.net/forum/affich-37584941-php-pdo-gerer-les-erreurs
    1
    1. Merci de ta réponse, je suis en train de regarder tout ça ! j'envoie la réponse au plus vite.
      0
      1. ligne 243 du fichier C:\xampp\htdocs\pmb\tables\install_rep.php :

        define('SQL_TYPE', 'mysql'); // Type de

        ligne 35 du fichier C:\xampp\htdocs\pmb\includes\mysql_functions.inc.php :

        } elseif ($username == null) {
        0
        1. Modérateur
          Si ton souci est résolu, penses à cliquer sur le lien "Marquer comme résolu" sous le titre de ta question.

          0
          1. Mon soucis n'est pas résolu.
            Je ne sais pas quoi faire avec les erreurs des lignes 243 et 35.

            De plus je ne sais pas comment installer les extension MySQLI ou PDO_MySQL.

            cordialement,
            0
            1. Modérateur
              Les extensions sont peut-être (voir sûrement....) déjà installées ...
              En ce qui concerne l'erreur de la ligne 243 .... comme je l'ai indiqué ... cela vient de l'extension mysql. Il faut donc re-coder toutes les instructions utilisant cette extension soit avec mysqli soit avec PDO.

              Pour l'erreur de la ligne 35, il semble qu'il y ait une variable nommée data_test qui n'a pas été initialisée au préalable.
              Dans un sens.. le message n'est qu'un "notice" et ne devrait donc pas être bloquant.
              Mais si tu veux corriger ce souci il faudrait que tu nous montres l'intégralité du fichier C:\xampp\htdocs\pmb\tables\install_rep.php
              0
          2. Modérateur
            Sinon .... tu pourrais simplement suivre les pré-requis pour installer ce logiciel....
            Comme indiqué sur leur site :

            Pré-requis techniques
            Serveur applicatif :
            Apache 2 minimum
            Mysql 5 mini
            PHP version 5.3

            Activer les extensions PHP : yaz, gd, iconv, curl, xslt, bz2, mime_magic


            https://www.sigb.net/index.php?lvl=cmspage&pageid=10&id_sous_rubrique_services=92

            Cordialement, 
            Jordane                                                                 
            0
            1. Très bien je vais réinstaller PMB, j'avais pris la version 4.2.1 de 2015 se trouvant sur le site que tu viens de m'envoyer.
              0
            2. Modérateur
              @Shulzy7Pas que pmb....
              Ton serveur apache/php aussi avec la bonne version
              0
            3. @jordane45Voici ma version de xampp 7.1.6 / PHP 7.1.6

              Includes: Apache 2.4.25, MariaDB 10.1.24, PHP 7.1.6, phpMyAdmin 4.7.0, OpenSSL 1.0.2, XAMPP Control Panel 3.2.2, Webalizer 2.23-04, Mercury Mail Transport System 4.63, FileZilla FTP Server 0.9.41, Tomcat 7.0.56 (with mod_proxy_ajp as connector), Strawberry Perl 7.0.56 Portable

              De plus, après réinstallation de pmb, mon message d'erreur à changé :

              lang = fr charset = utf-8
              user = bibli; password = bibli; dbhost = localhost; dbname = bibli
              usersystem = root; passwordsystem = ; dbhost = localhost; dbnamesystem =

              Fatal error: Uncaught Error: Call to undefined function mysql_connect() in C:\xampp\htdocs\pmb\includes\mysql_functions.inc.php:35 Stack trace: #0 C:\xampp\htdocs\pmb\tables\install_rep.php(296): pmb_mysql_connect('localhost', 'root', '') #1 {main} thrown in C:\xampp\htdocs\pmb\includes\mysql_functions.inc.php on line 35
              0
            4. Modérateur
              @Shulzy7Tu es en php 7 ..... il faut du 5.3 !
              0
            5. @jordane45Bonjour, j'ai réinstallé la version 1.7.1 mais je n'arrive plus à lancer Apache, l'erreur :

              Busy...
              Service Apache Started

              C'est un problème avec le port 80, je l'avais résolu avec l'autre version mais cette fois ci, la manipulation ne marche pas.

              Je crois savoir d'ou peut venir le problème, quand je vais dans
              démarrer -> éxécuter -> services.msc
              il y a deux versions d'Apache, pourtant j'ai supprimé l'ensemble des fichiers xampp, pmb..
              0