Somme en fonction des mois de l'année

Résolu/Fermé
Signaler
Messages postés
7
Date d'inscription
lundi 1 mai 2017
Statut
Membre
Dernière intervention
1 mai 2017
-
Messages postés
26314
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 décembre 2021
-
Bonjour à tous,
j'ai besoin de votre aide. J'ai deux colonnes.

Colonne A avec des dates avec format mois/année et colonne B avec des heures de travail.

j'aimerai calculer les sommes des heures de la colonne B en fonction du mois.

Donc, si j'ai 4 cellules avec différentes heures de février 2017 de les totaliser ensemble.
ce qui va donner:
Somme février-2017 = xxxx.
somme mais - 2017 = yyyy
somme janvier-2016 = zzzz

Pourriez vous m'aidez svp ?

merci

4 réponses

Messages postés
26314
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 décembre 2021
6 132
Bonjour
pour un champ de A1 à A100 (à adapter)

=SOMMEPROD((MOIS(A1:A100=1)*(B1:B100))
=1 pour janvier
=2 pour Février
etc...

(N° de ligne recommandé" pour limiter les champs
ex: A1:A100 plutôt que A:A)
crdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
7
Date d'inscription
lundi 1 mai 2017
Statut
Membre
Dernière intervention
1 mai 2017

Merci Vaucluse,
j'ai essayé mais ca ne marche pas. j'ai plutôt la somme de toute la colonne.
Messages postés
55103
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
6 décembre 2021
17 022 >
Messages postés
7
Date d'inscription
lundi 1 mai 2017
Statut
Membre
Dernière intervention
1 mai 2017

La formule de Vaucluse fonctionne si tu ajoutes la parenthèse manquante :
=SOMMEPROD((MOIS(A1:A100
 ) 
=1)*(B1:B100))
Messages postés
55103
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
6 décembre 2021
17 022
Bonjour. Oui, on peut t'aider. Envoie ton fichier.
 1) Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers
Messages postés
2675
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
5 décembre 2021
1 240 >
Messages postés
7
Date d'inscription
lundi 1 mai 2017
Statut
Membre
Dernière intervention
1 mai 2017

oui
MOIS(F6) = le N° du mois donnée en F6
Messages postés
7
Date d'inscription
lundi 1 mai 2017
Statut
Membre
Dernière intervention
1 mai 2017
>
Messages postés
2675
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
5 décembre 2021

Mon cher ca ne fonctionne malheureusement pas
Messages postés
3509
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
1 décembre 2021
1 023 >
Messages postés
7
Date d'inscription
lundi 1 mai 2017
Statut
Membre
Dernière intervention
1 mai 2017

Bonjour,

un autre proposition ; testée elle fonctionne :

=SOMMEPROD((MOIS($B$2:$B$301)=MOIS(F6))*(VALEURNOMBRE($C$2:$C$301)))

Cordialement
Messages postés
55103
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
6 décembre 2021
17 022 >
Messages postés
7
Date d'inscription
lundi 1 mai 2017
Statut
Membre
Dernière intervention
1 mai 2017

La formule de Yclick fonctionne si tu remplaces
MOIS($B$2:$B$301)=MOIS(F6);
par
(MOIS($B$2:$B$301)=MOIS(F6))*
ce qui donne la formule
=SOMMEPROD
 ( 
(MOIS($B$2:$B$301)=MOIS(F6)
 )* 
$C$2:$C$301)
Messages postés
7
Date d'inscription
lundi 1 mai 2017
Statut
Membre
Dernière intervention
1 mai 2017
>
Messages postés
55103
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
6 décembre 2021

Merci les Boys,
ca fonctionne pour le mois, mais le problème est que cela additionne les mois sans tenir compte de l'année.

y'a t'il une possibilité d'afficher les somme selon le mois et l'année, si possible ??

merci d'avance
Messages postés
55103
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
6 décembre 2021
17 022
piposula, tu disposes maintenant de 3 formules qui fonctionnent.
Je te recommande cependant celle de Yclick : elle autorise la recopie vers le bas et est plus courte que celle de PapyLuc51.

Bonne fin de week-end prolongé à vous trois !
Messages postés
7
Date d'inscription
lundi 1 mai 2017
Statut
Membre
Dernière intervention
1 mai 2017

MERCI À TOUS
Messages postés
26314
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 décembre 2021
6 132
Effectivement, comme d'hab, j'ai raté une parenthèse
pour inclure les années, il suffit de rajouter un item dans SOMMEPROD

=SOMMEPROD((MOIS(A1:A100)=1)*(ANNEE(A1:A100)=2017)*(B1:B100))

cette fois toutes les parenthèses y sont :-(
crdlmnt