Erreur Automation

Résolu/Fermé
CCM_lfrt
Messages postés
3
Date d'inscription
mercredi 25 novembre 2015
Statut
Membre
Dernière intervention
30 avril 2017
- 27 avril 2017 à 16:51
CCM_lfrt
Messages postés
3
Date d'inscription
mercredi 25 novembre 2015
Statut
Membre
Dernière intervention
30 avril 2017
- 30 avril 2017 à 11:26
Bonjour,
Si quelqu'un a la solution de mon problème je lui serai infiniment reconnaissant de me communiquer la solution. J'ai beau chercher je ne trouve pas de réponse. Voici le problème.
Je suis passé de OFFICE 2010 à OFFICE 2016.
En Excel toutes mes anciennes Macros fonctionnent sans problème.
En WORD toutes mes Macros aboutissent en un message "Erreur Automation".
D'avance grand merci pour vos suggestions.
Louis



A voir également:

2 réponses

m@rina
Messages postés
17468
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
16 juillet 2022
10 932
29 avril 2017 à 03:49
Bonjour,

Il peut y avoir quelques fonctions VBA qui ne passent pas de 2010 à2016, assez peu mais suffisamment pour bloquer.

Regarde en particulier du côté des ActiveX et des contrôles de formulaire. Je me souviens avoir des problèmes avec les ActiveX qui n'étaient plus reconnus. Il suffisait de les refaire.

m@rina
1
CCM_lfrt
Messages postés
3
Date d'inscription
mercredi 25 novembre 2015
Statut
Membre
Dernière intervention
30 avril 2017

30 avril 2017 à 11:26
Je vous suis infiniment reconnaissant. Suite à votre recommandation j'ai simplement exporté une macro contenant un ActiveX vers un fichier pour ensuite (ré)importé ce fichier dans VBA et toutes les macros (une dizaine) ont fonctionné correctement.
Et dire que j'ai, pendant des heures, essayé sans succès d'autres recommandations.
Encore grand merci,
LL
0