Compter le nombre de valeurs uniques avec une certain préfixe [Résolu/Fermé]

Signaler
-
 GRM -
Bonjour,

Pour un projet je souhaiterai compter le nombre de valeurs uniques avec un certain préfixe dans une colonne. Par exemple :

Colonne 1
C 1
D 1
C 2
C 1
A 3
C 3
C 2
B 2
C 4

Je souhaiterai connaitre le nombre de valeurs différentes (uniques) commençant par C. ( Le calcul devrait donc afficher 4 )

Je vous remercie pour votre aide car là je commence à tourner en rond ;)



2 réponses

Messages postés
25863
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 mars 2021
5 812
Bonjour
strictement adapté à la liste que vous donnez, pas sur que ça fonctionne dans tous les cas.
Si problème revenez avec un modèle plus complet de vos données
la formule pour une liste de A2 à A10

=SOMME(SI(GAUCHE($A$2:$A$10;1)="C";1/NB.SI($A$2:$A$10;$A$2:$A$10)))

attention: formule matricielle à entrer avec la touche enter en maintenant les touches ctrl et shift enfoncées.
(elle s'affiche automatiquement entre accolades dans la barre de formule)
crdlmnt
Merci pour cette réponse Vaucluse !! Cela semble marcher.

Bonne journée !