Extraire les deux premières lettres d'une chaîne de mots

Résolu/Fermé
Claire - 21 févr. 2017 à 19:10
PHILOU10120 Messages postés 6174 Date d'inscription lundi 16 avril 2012 Statut Contributeur Dernière intervention 4 décembre 2022 - 22 févr. 2017 à 15:31
Bonjour à tous,

J'ai besoin d'aide car je bute sur la dernière étape de ma formule excel.
Je vous explique, je cherche a créer une référence produit en automatique. La désignation possède de 1 à 4 mots. Lorsqu'il n'y a qu'un seul mot dans la désignation, la formule doit donner les 4 premières lettre du mot unique. Lorsque la désignation possède 2 mots et plus, elle doit donner les 2 premières lettres de chaque mot qui compose la désignation.

Exemple (au pif)
Désignation 1 : Moissonneuse => Ref : MOIS
Désignation 2 : Moissonneuse Batteuse => Ref : MOBA
Désignation 3 : Moissonneuse Batteuse Faucheuse => Ref : MOBAFA

Voici ma formule :

Pour les désignations avec un seul mot (formule ok)
=SI((NBCAR(D2)-NBCAR(SUBSTITUE(D2;" ";""))+1)=1;(GAUCHE(D2;4));)

Formule à la suite de la première => pour les désignations avec 2 mots (formule ok)
&(SI((NBCAR(D2)-NBCAR(SUBSTITUE(D2;" ";""))+1)=2;(GAUCHE(D2;2)&STXT(D2;CHERCHE(" ";2)+1;2));))

Formule à la suite de la seconde => pour les désignations avec 3 mots (formule ok)
&(SI((NBCAR(D8526)-NBCAR(SUBSTITUE(D8526;" ";""))+1)=3;(GAUCHE(D2;2)&STXT(D2;CHERCHE(" ";D2)+1;2)&STXT(D2;(CHERCHE(" ";D2;CHERCHE(" ";D2;1)+1))+1;2));))

La formule que j'ai pour les désignations à 4 mots ne fonctionne pas, quelqu'un aurait une idée pour m'aider?

Merci d'avance, c'est très important pour moi



8 réponses

DjiDji59430 Messages postés 3681 Date d'inscription samedi 19 avril 2008 Statut Membre Dernière intervention 5 décembre 2022 563
21 févr. 2017 à 19:45
Bonjour,

Un essai

https://www.cjoint.com/c/GBvsThyRzpi

Crdmt
0