Erreur balise <head> et <body>... [Résolu/Fermé]

Signaler
Messages postés
238
Date d'inscription
mardi 18 août 2015
Statut
Membre
Dernière intervention
23 mars 2019
-
Messages postés
1709
Date d'inscription
vendredi 6 mars 2009
Statut
Membre
Dernière intervention
24 septembre 2018
-
Bonjour,

Après avoir passé le code source d'une des pages de mon site web sur le service de validation du W3C, je remarque 2 erreurs dont je ne vois absolument pas la raison. J'ai fait plusieurs recherches, sans succès...

Ces deux erreurs sont :
- Stray end tag <<head>>
- Start tag <<body>> seen but an element of the same type was already open.

Autrement dit :
- Balise de fin isolée « head ».
- Une balise ouvrante « body » a été rencontrée mais un élément du même type était déjà ouvert.

Merci de votre aide,

hcp7kuz

2 réponses

Messages postés
1709
Date d'inscription
vendredi 6 mars 2009
Statut
Membre
Dernière intervention
24 septembre 2018
762
Il dit que le body est ouvert deux fois, donc tu dois avoir une balise body imbriquée dans une autre et aussi que le head n'est pas fermé. Enfin sans le code c'est difficile car l'interprétation du w3c est particulière selon la mise en page

--
Messages postés
238
Date d'inscription
mardi 18 août 2015
Statut
Membre
Dernière intervention
23 mars 2019
12
Problème résolu, malgré une bonne dizaine de vérification, une erreur toute simple m'est passé sous le nez : j'avais inséré des éléments sensés être dans le <body> dans le <head>.
Messages postés
1709
Date d'inscription
vendredi 6 mars 2009
Statut
Membre
Dernière intervention
24 septembre 2018
762
Oui t'inquiète pas ça arrive même avec de l'expérience de mal fermé une balise ou d'oublier un ; en Php par exemple

--