Installation Eclipse sur Mac [Résolu/Fermé]

Signaler
-
 Marion -
Bonjour, je me permets de poster ce message afin de savoir si quelqu'un peut m'aider : je suis actuellement en train d'installer Eclipse dans le but de programmer en Java. Mais au moment de terminer cette installation j'ai un message d'erreur qui apparaît : version 1.7.0_79 of the JVM is not suitable for this product. Version 1.8 or greater is required. Mais lorsque je me rends dans mes paramètres Java on m'indique que j'ai la version Java 8 mise à jour 112. Que dois-je faire ?
En vous remerciant par avance,

2 réponses

Messages postés
592
Date d'inscription
vendredi 7 août 2009
Statut
Membre
Dernière intervention
3 juin 2017
102
Hello,

Tu peux modifier la version utilisée par eclipse de la manière suivante sur Mac :

Clic Droit sur l'Application Eclipse --> Afficher le contenu du paquet --> Content --> Eclipse --> Ouvre eclipse.ini avec un éditeur de texte.

Tu devrais apercevoir une ligne de ce style :

-vm
/Library/Java/JavaVirtualMachines/jdk1.7.0_79.jdk/Contents/Home/jre/bin


Tu peux la changer pour pointer vers ton jdk1.8.0_112.

Pour infos les différentes version de JDK sous mac sont stockées sous
/Library/Java/JavaVirtualMachines/

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Super c'est bon merci !
Messages postés
16301
Date d'inscription
samedi 31 mai 2008
Statut
Modérateur
Dernière intervention
7 avril 2021
2 817
Bonjour,

Tu peux faire un
which java
(Linux/Mac) ou
where java
(Windows) pour lister toutes les versions Java accessibles depuis le PATH, qu'il faudra modifier s'il est incorrect (il faudrait qu'elle contienne la valeur Java 8 voulue)