Chercher un mot dans une cellule

Résolu/Fermé
nonossov
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020
- 25 juil. 2016 à 15:52
nonossov
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020
- 26 juil. 2016 à 12:09
Bonjour Mes amis,

j'ai besoin de votre aide à trouver un mot dans une cellule et de donner la valeur qui lui corespondante ; par exemple la cellule A1 contient les mots Smart vision technologie, et dans la cellule B1 contient 100,

je veux savoir la formule que je peux utiliser pour chercher le mot vision dans A1 et de me donner la valeur corespondante.

pour information j'ai utilisé cette formule pour savoir la valuer corresponadte d'un seul mot maintenant j'ai besoin de trouver un mot dans une phrase par excemple.

=+RECHERCHEV(A1;Feuil2!$A:$B;2;0)

merci d'avance mes amis!


A voir également:

2 réponses

Unombre
Messages postés
40
Date d'inscription
lundi 11 juillet 2016
Statut
Membre
Dernière intervention
8 septembre 2017
16
25 juil. 2016 à 15:56
Salut,

Tu peux faire ca :
=SI(NB.SI(A1;"*vision*");B1;"")
5
nonossov
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

26 juil. 2016 à 11:35
Bonjour Mr,
Oui cette formule peut me servir, mais est ce qu'on peut cherche un mot sans l'ecrire dans la formule: Par exemple dans la meme formule:

=SI(NB.SI(A1;"A2");B1;"")
on chercher le mot écrit dans A2 ou lieu de l'ecrire dans la formule??

Merci infiniment
0
Unombre
Messages postés
40
Date d'inscription
lundi 11 juillet 2016
Statut
Membre
Dernière intervention
8 septembre 2017
16 > nonossov
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

26 juil. 2016 à 11:50
Bien sur, ce sera alors :

=SI(ESTERR(TROUVE(A2;A1));"";B1)


Ça cherche A2 dans A1 si oui, alors B1 sinon rien

Il existe bien d'autre méthode bien évidement, peut être que celle la te correspondra mieux.
1
nonossov
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

26 juil. 2016 à 12:09
Merci infiniment Mr Unombre!!!
0