Erreur de compilation type défini par l'utilisateur non défini [Résolu/Fermé]

Signaler
Messages postés
92
Date d'inscription
mercredi 16 octobre 2013
Statut
Membre
Dernière intervention
6 août 2020
-
Messages postés
92
Date d'inscription
mercredi 16 octobre 2013
Statut
Membre
Dernière intervention
6 août 2020
-
Bonjour à tous,

Dans la macro ci-dessous, j'ai le message d'erreur "erreur de compilation type défini par l'utilisateur non défini" qui apparaît.
Pouvez-vous m'aider SVP ?
Merci à vous.

Private Sub CommandButton1_Click()
Dim derligne As Interger
If MsBox("Confirmez-vous l'ajout d'un nouveau Client ?", vbYesNo, "Confirmation") = vbYes Then
derligne = Sheets("Clients").Range("A456541").End(xlUp).Row + 1
Cells(derligne, 1) = TextBox1.Value
Cells(derligne, 2) = TextBox1.Value
Cells(derligne, 3) = TextBox1.Value
Cells(derligne, 4) = TextBox1.Value
Cells(derligne, 5) = TextBox1.Value
Cells(derligne, 6) = TextBox1.Value
Cells(derligne, 7) = TextBox1.Value
Cells(derligne, 8) = TextBox1.Value
Cells(derligne, 9) = TextBox1.Value
Cells(derligne, 10) = TextBox1.Value
End If
End Sub

3 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 149
Bonjour,

Dim derligne As Interger 

Normalement tu aurais dû la trouver tout seul !
En plus évite d'utiliser "integer" pour la ligne préfère "long" car si ta feuille grandi, tu vas chercher un dépassement de capacité.
Messages postés
92
Date d'inscription
mercredi 16 octobre 2013
Statut
Membre
Dernière intervention
6 août 2020
2
Bonjour gbinforme,

Merci beaucoup pour ton retour, c'est vrais que moi et l'Anglais, on est pas copain, lol, et n'oublions pas que je débute !!!!
Ce problème résolu, un autre est apparu, Grrrrrrrr.
Il apparaît dans le "If MsBox"
"erreur de compilation, Sub ou Fonction non définie"
Je ne vois pas où est l'erreur dans ma ligne.
Pouvez-vous m'aider ?
Merci à vous.
Messages postés
92
Date d'inscription
mercredi 16 octobre 2013
Statut
Membre
Dernière intervention
6 août 2020
2
Aie, désolé !!!
c'était encore une erreur de frappe, oubli dans "MsBox"
Avec le "g" ça va mieux, donc "MsgBox" ça marche.

Merci à tous et bon dimanche.....