Fetchmail erreur Socket.

[Résolu/Fermé]
Signaler
Messages postés
927
Date d'inscription
mercredi 11 août 2004
Statut
Membre
Dernière intervention
12 novembre 2020
-
Messages postés
927
Date d'inscription
mercredi 11 août 2004
Statut
Membre
Dernière intervention
12 novembre 2020
-
Bonjour,

Dans l'endroit où je suis, on n'a pas d'adresse IP Fixe, donc les sociétés qui utilisent leur propre domaine de messagerie sont obligées de faire du catchall.

J'ai un serveur de messagerie avec postfix, qui fonctionne bien, mais je me suis rendu compte que parfois avec certains messages, j'ai des erreurs lors de la récupération sur la boite globale.

Ainsi, certains messages bloquent la réception, je suis obligé de les déplacer pour les mettre de coté, mais j'ai eu du mal à comprendre pourquoi.

Je pense que ça vient de l'entête qui serait mal formé. le message est généré par un client Lotus Notes Release 8.5.3 qui est une ancienne version de ce produit et il parait que suivant la configuration, il respectait plus ou moins la structure des entêtes de messages. ( fixée par la RFC822)
Je ne sais pas si c'est réellement ça, mais en tout cas, le point commun aux messages qui provoquent l'erreur est bien d'être en Lotus Notes et de provenir de la même personne.

Est-ce que quelqu'un a déjà eu le problème avec fetchmail.
J'ai trouvé beaucoup d'information sur les paramètres, mais rien sur ce cas en particulier.




1 réponse

Messages postés
927
Date d'inscription
mercredi 11 août 2004
Statut
Membre
Dernière intervention
12 novembre 2020
297
Bonjour,

Finalement, en jouant avec la paramètre "envelope" et le paramètre aka, en regardant les flots de log de fetchmail en mode archi-verbeux... on a fini par se débrouiller...

Clôture de l'incident.