Mail():Failed to connect to mailserver[php] [Résolu/Fermé]

Signaler
Messages postés
106
Date d'inscription
lundi 16 juillet 2007
Statut
Membre
Dernière intervention
31 mai 2008
-
Messages postés
3
Date d'inscription
dimanche 12 mai 2013
Statut
Membre
Dernière intervention
4 novembre 2013
-
Bonjour tout le monde
S'il vous plait c quoi la solution a ce probleme,verifier smtp mais comment ??
Warning: mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in c:\program files\easyphp1-8\www\gestion\envoyer_email.php on line 94

19 réponses

Messages postés
12
Date d'inscription
dimanche 3 juin 2007
Statut
Membre
Dernière intervention
1 février 2009
22
C'est donc normal que cela ne marche pas!!!
Tu mets un SMTP qui ne correspond pas a ton FAI
MAROC TELECOM C EST MENARA C CA?
SI OUI ALORS
le smtp est : smtp.menara.ma
Tu met au debut de ton script
ini_set('SMTP','smtp.menara.ma');
23
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 56974 internautes nous ont dit merci ce mois-ci

Messages postés
106
Date d'inscription
lundi 16 juillet 2007
Statut
Membre
Dernière intervention
31 mai 2008

et bien merci beaucoup sfinxrecord , ca a marche !
a bientot avec une nouvelle betise :D
Messages postés
14
Date d'inscription
lundi 11 août 2008
Statut
Membre
Dernière intervention
12 novembre 2008

j'ai le meme probléme smtp:

Warning: mail(): Failed to connect to mailserver at "smtp.topnet.fr" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in d:\program files\easyphp1-8\www\reclamation\rdv.php on line 20

jai utilisé la fonction ini_set('SMTP','smtp.topnet.fr');
je suis en tunisie et topnet est mon FAI mais ça marche pas est ce que vous pouvez m'aider?
j'ai cette probleme comment je peux coriger?????????
Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set()
Messages postés
3
Date d'inscription
dimanche 12 mai 2013
Statut
Membre
Dernière intervention
4 novembre 2013

@mayfree: tu doit mettre ini_set('SMTP','smtp.topnet.tn'); et inchalla tout va bien
Configures easyPhp pour l'envoi de mails notament smtp

Je ne connais pas easyphp alors je ne peux pas trop d'aiguiller. Vois le php.ini
Messages postés
106
Date d'inscription
lundi 16 juillet 2007
Statut
Membre
Dernière intervention
31 mai 2008

salut merci Alain
voila je ai ouvert php.ini et jai trouve :

[mail function]
; For Win32 only.

SMTP = localhost

; For Win32 only.
sendmail_from = me@localhost.com

; For Unix only. You may supply arguments as well (default: "sendmail -t -i").
;sendmail_path =

Comme tu vois SMTP=localhost ,dans des forum j ai trouve k il faut remplacer localhost par wanadoo.fr ou autre..
mais ca marche tjrs pas.
Peut etre smtp.orange.fr
Messages postés
929
Date d'inscription
mercredi 28 mai 2008
Statut
Membre
Dernière intervention
16 juin 2013
79
mon script de mail :
ini_set("SMTP","smtp.gmail.com");


mon php.ini :
[mail function]
; For Win32 only.
SMTP = smtp.gmail.com
smtp_port = 465



Erreur :

L'email n'a pu être envoyé ! send() :: Warning ! : mail() [function.mail]: Failed to connect to mailserver at "smtp.gmail.com" port 465, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in class.mailer.php on line 1737

Fichier : engine_send.php Ligne : 584



:( je n'arrive toujours pas a envoyer mes mails ...
Pour gmail, il faut utiliser l authentification SSL, presque aucun script ne supporte l encryption SSL en php actuelement, la seul solution est d utiliser la librarie MAIL5 en mode TLS pour gmail.
Messages postés
929
Date d'inscription
mercredi 28 mai 2008
Statut
Membre
Dernière intervention
16 juin 2013
79 > sora oseka
Le post est vieux mais merci quand même !!! :)
je ss au maroc et j'ai meditel
comment je peux configurer mon smtp
Messages postés
1
Date d'inscription
mercredi 8 novembre 2006
Statut
Membre
Dernière intervention
22 septembre 2007
1
c'est normal que tu tombe dans ce probléme , parce que tu doit configurer votre smtp "le serveur des mail"
et pour cela tu doit y aller au :C:\Program Files\EasyPHP1-8\apache\php.ini
et tu doit configurer le smtp en le modifiant en
smtp=menara.ma
essayez cela il fonctionne chez moi
allez bonne journée
Messages postés
12
Date d'inscription
dimanche 3 juin 2007
Statut
Membre
Dernière intervention
1 février 2009
22
Exactement
En conclusion , soit le configurer sur le script qui utilise la fonction mail :
- Avec la fonction ini_set("SMTP","nom du smtp" )
- Ou le configurer dans le php.ini comme l'explique saviola77
---------------------------------------------
[mail function]
; For Win32 only.
SMTP = nom du smtp
---------------------------------------------------
salut tout lemonde j'ai le méme probleme j'ai configurer mon stmp a menara .ma car je travailler par un modem maroc telecom mais toujour le meme probleme Warning: mail() [function.mail]: Failed to connect to mailserver at "menara.ma" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\wamp\www\html5php.com\www\reservation.php on line 111
Messages postés
106
Date d'inscription
lundi 16 juillet 2007
Statut
Membre
Dernière intervention
31 mai 2008

non c pas wanadoo orange , c au maroc et c 'est maroc telecom :D
comme conclution est ce qu'on peut dire qu'on doit preciser le smtp du provider (hebergeur)
si mon site est heberger par exemple sur free.fr je doit modifier la cinfig en (smtp=smtp.free.fr) mais est ce que ca marchera en local
Messages postés
929
Date d'inscription
mercredi 28 mai 2008
Statut
Membre
Dernière intervention
16 juin 2013
79
Bonjour tout le monde j'ai le même souci, il faut que je configure le serveur mail, mais comment faire lorsqu il s'agit d'un reseau d'entreprise et que l'on ne connaisse pas le FAI ??

Merci a vous
SVP , je ss à Tunis , mon fournisseur est Planet
comment je peux configurer mon smtp
smtp.planet.tn
Messages postés
4
Date d'inscription
mardi 29 avril 2008
Statut
Membre
Dernière intervention
1 septembre 2009

bonsoir les amis
j' ai à peu pres le mm pb ! sauf que avant je travaillait avec comme provider iam et dc smtp.menar.ma ca marchait!
mnt j ai changé pr wana, j ai fait les modifs necessaires ds mon "php.ini" à savoir (SMTP = smtp.wanamail.ma ) et ca donne l erreure suivante :
"SMTP server response: 554 5.7.1 <wana-xxx-xxx-xx-xxx.wanamaroc.com[xxx.xx.xxx.xxx]>: Client host rejected: Access denied "
qlq aurait il une idee ? merci d avance
ton ISP utilise avant le SMTP l'authentification POP il faut juste ajouter avant pop=pop._ton fournisseur
auth_user=ton_login_mail
auth_pâss=ton_pass_mail
verifie avnt la syntaxe ..
bonne chance :)
Messages postés
4
Date d'inscription
mardi 29 avril 2008
Statut
Membre
Dernière intervention
1 septembre 2009

merci bcp mejdi331
je ne vois pas comment ajouter :
pop=pop._ton fournisseur
auth_user=ton_login_mail
auth_pâss=ton_pass_mail
dans "php.ini"
en tt cas merci. Pour l insatnt je suis entrain d explorer la possibilité d installer un serveur mail local qui s occupe de l'identification /authentification
salut tout le monde, mon fournisseur c fawri et je suis d'algerie, je sais pas dutout quoi fairen c'est un vrai casse tete, malgré que j'ai essayé de le faire en local avec le hMailerServer et ca marche tjrs pas

Merci
Messages postés
297
Date d'inscription
dimanche 30 mars 2008
Statut
Membre
Dernière intervention
2 février 2017
13
salut riham j'ai le meme problème!! je ss d'algérie et j'ai fawri!
comment faire est ce que ta résolu ton problème?
Messages postés
106
Date d'inscription
lundi 16 juillet 2007
Statut
Membre
Dernière intervention
31 mai 2008

salut
j'insiste encore ;) personne n a une idee svp
Messages postés
106
Date d'inscription
lundi 16 juillet 2007
Statut
Membre
Dernière intervention
31 mai 2008

j ai esseye smtp.orange.fr et ca a donne l erreur suivante :

Warning: mail(): SMTP server response: 554 <majdouline_sana@hotmail.com>: Recipient address rejected: Missing Authentication in c:\program files\easyphp1-8\www\gestion\envoyer_email.php on line 104


la ligne 104 est :

mail("majdouline_sana@hotmail.com",$_POST['sujet'],$_POST['message'],"From: ".$_POST['nom']."<".$_POST['email'].">");
Messages postés
12
Date d'inscription
dimanche 3 juin 2007
Statut
Membre
Dernière intervention
1 février 2009
22
Force ta configuration SMTP avec la fonction ini_set

place ca au debut de ton script qui te sert a envoyer ton mail

ini_set("SMTP","smtp.wanadoo.fr");

Ca change la valeur qui se trouve dans ton php.ini pendant le tps d'éxécution de ton script
Messages postés
106
Date d'inscription
lundi 16 juillet 2007
Statut
Membre
Dernière intervention
31 mai 2008

salut tt le monde,
Merci sfinxrecord, j ai esseye ce que tu m'as suggere mais ca marche toujours pas, ca donne la meme erreur :

Warning: mail(): Failed to connect to mailserver at "smtp.wanadoo.fr" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in c:\program files\easyphp1-8\www\gestion\envoyer_email.php on line 106

et kand je mets : smtp.orange.fr ,ca donne l'erreur suivante :

Warning: mail(): SMTP server response: 554 <majdouline_sana@hotmail.com>: Recipient address rejected: Missing Authentication in c:\program files\easyphp1-8\www\gestion\envoyer_email.php on line 104
Messages postés
12
Date d'inscription
dimanche 3 juin 2007
Statut
Membre
Dernière intervention
1 février 2009
22
Quel est ton Fournisseur acces Internet? C'est bien wanadoo orange?
Messages postés
1
Date d'inscription
mercredi 19 août 2009
Statut
Membre
Dernière intervention
20 août 2009

bonjour je suis débutante en php , et j'ai un problème lors de l envoie d'un mail
j'ai une erreur qui apparaitre sur la page :

Warning: Failed to Connect in d:\02serveur16\procedures\sitesmaville-1-2\administration\pro\requete.php on line 442
Echec de l’envoi du mail.

est ce que quelqu un connais la reponse