MySQL : 1045 access denied for root [Fermé]

Signaler
-
 betty -
J'ai installé puis desinstallé mysql ; en le reinstallant de nouveau

et en utilisant le Wizard fourni : Access denied 1045=> doit y avoir quelque qu'il n'a pas desinstallé !!!

13 réponses

Messages postés
3
Date d'inscription
mercredi 13 février 2008
Statut
Membre
Dernière intervention
13 février 2008
240
salut voila un peu tard mais au cas ou


#1045- Access denied for user ‘root’@localhost’

Pour ceux qui ont un problème d’ouverture de PhpMyAdmin avec Access Denied :

#1045- Access denied for user ‘root’@localhost’

Il est nécessaire d’effectuer quelques manipulations après l’installation :

Ouvrez la console MySql,

Après avoir tapé Entrée et avoir la commande mysql> :

Il est utile de commencer par attribuer le nouveau mot de passe via la commande :

SET PASSWORD FOR root@localhost=PASSWORD(' monmotdepasse ');

Ensuite il n’est pas inutile de réattribuer les droits de super utilisateur via la commande :

mysql> GRANT ALL PRIVILEGES ON *.* TO root@localhost
-> IDENTIFIED BY ' monmotdepasse ' WITH GRANT OPTION;

Bien évidemment il faut insérer les noms de host et de compte user par défaut avec le mot de passe mis en place dans le fichier ‘php.ini’, au niveau suivant :

; Default host for mysql_connect() (doesn't apply in safe mode).
mysqli.default_host ='localhost'

; Default user for mysql_connect() (doesn't apply in safe mode).
mysqli.default_user ='root'

; Default password for mysqli_connect() (doesn't apply in safe mode).
; Note that this is generally a *bad* idea to store passwords in this file.
; *Any* user with PHP access can run 'echo get_cfg_var("mysqli.default_pw")
; and reveal this password! And of course, any users with read access to this
; file will be able to reveal the password as well.
mysqli.default_pw ='monmotdepasse'

Et il ne reste plus qu’à effectuer l’implantation des noms de host et de compte user par défaut avec le mot de passe dans le fichier ‘config.inc.php’ aux lignes suivantes:

$cfg['Servers'][$i]['host']= 'localhost';

$cfg['Servers'][$i]['user'] = 'root';

$cfg['Servers'][$i]['password']= 'monmotdepasse';

Et là après n’avoir pu seulement ouvrir correctement la page localhost, vous allez avoir l’agréable surprise de pouvoir vous connecter à PhpMyAdmin sans l’erreur :

#1045- Access denied for user ‘root’@localhost’


Cordialement,

Julien du 49.
211
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Bonjour,

J'ai fait exactement toutes les manipulations et maintenant drupal ne m'affiche plus rien mais ne me fait pas passer à l'étape suivante pour autant...
Quelqu'un a eu le même problème et a trouvé une solution?
Nan mais c ridicule !!
En ce qui me concerne, je n'arrivais pas à accéder à la console (mysql.exe sous Windows) justement parce que je n'avais pas le mot de passe root...

La page suivante m'a indiqué comment relancer MySQL en mode "non protégé" pour accéder à la console sans entrer le mot de passe : http://www.debian-administration.org/articles/442 (oui, un site Debian m'a aidé bien que je sois sous Windows :-). En espérant que cela aidera quelqu'un...
J'étais au bord du craquage, depuis trois jours que je traînais cette erreur 1045.
Je suis sous Ubuntu 11.04 et j'ai suivi à la lettre http://www.debian-administration.org/articles/442 (merci Rubis).
C'était mon 10e essai de réparation de ce serveur MySQL eh bien ça y est, ça marche. Qu'Allah, Bouddha et Jéhovah vous bénissent !
En plus de la solution de JUJUZILLA, il faudra ouvrir le fichier 'config.inc.php' qui se trouve pour ma part à cette adresse: C:\Program Files (x86)\wamp\apps\phpmyadmin3.5.1
Puis l'ouvrir avec Notepad++, les réglages seront plus faciles...Mais attention, lorsqu'on recoit cette erreur, il y a comme 'password: NO' juste après. LA SOLUTION (si malgré tout le problème persiste), c'est de transformer la valeur 'true' dans notepad++ par la valeur 'false'.
Aussi, il y a un risque que l'enregistrement de la modification ne prenne pas effet, dans ce cas, cliquer-deposer sur le bureau -> Ouvrir avec Notepad++ (qui reconnait le langage et colore la syntaxe) -> Faire ses modifications->Enrégistrer(CTRL+S)->Fermer->Glisser-déposer dans 'C:\Program Files (x86)\wamp\apps\phpmyadmin3.5.1 (je ne sais pas chez vous)'. Il vaut donc mieux laisser la fenetre de ce dossier ouverte pour plus de simplicité.
Aufwiedersehen :)
!Pour plus de sécurité éviter cette connection automatique sur PhpMyadmin.

$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password']= 'monmotdepasse';


Essayer plutôt de changer cette ligne:

$cfg['Servers'][$i]['auth_type'] = 'config';

par:

$cfg['Servers'][$i]['auth_type'] = 'http';

Ce qui aura pour but d'afficher la boite de dialogue d'authentification lors de l'acces à PhpMyadmin.
merci bcp pour cette astuce en fait j'ai bcp de temps à chercher et en fin merci
Bonjour, j'avais exactement le même problème!!
J'ai tout réglé grâce au post de jujuzilla :p

C'est cette partie là qui a débloqué la situation :

Et il ne reste plus qu’à effectuer l’implantation des noms de host et de compte user par défaut avec le mot de passe dans le fichier ‘config.inc.php’ aux lignes suivantes:

$cfg['Servers'][$i]['host']= 'localhost';

$cfg['Servers'][$i]['user'] = 'root';

$cfg['Servers'][$i]['password']= 'monmotdepasse';

Au début je croyais que c'était pas ça, car tout semblait déjà bien !
(Et je me suis ensuite rappelé par la suite qu'il y avait plusieurs fichier config.inc.php !
J'ai fais une recherche de tout les fichier, avec la commande (sous linux) :

find / -name config.inc.php

J'ai ouvert chaque fichier un par un, j'ai édité un par un (j'ai dé-commenté l'un des fichier (enlever les // devant les "$" , et j'ai rajouté les lignes dans un autre!)

Bref je redémarre mon serveur, et là MAGIE!! Je n'ai plus l'erreur je peux enfin y avoir accès!
Bref ça faisait trois joueurs que je bloquais, et j'avais vraiment pas envie de tout réinstaller.

Alors à un grand merci, et j'espère que mon post pourra en aider certains.
Messages postés
302
Date d'inscription
dimanche 14 octobre 2007
Statut
Membre
Dernière intervention
13 mai 2014
37
Merci beaucoup.
j'ajouterais que config.inc.php se trouve ici C:\wamp\apps\phpmyadmin3.2.0.1
bien à vous.
J'ai aussi rencontré ce problème qui survient quand on a déjà fait une installation de MySQL.

Sous Windows 7, il faut effacer à la main tous les fichiers/répertoires créés par MySQL, sans oublier celui qui est mis dans C:\Users\All Users\ (et oui All Users pas uniquement le User qui a fait l'installation).

Ce répertoire est caché ET protégé par le système, vous devrez donc désactiver les options dans 'Options des dossiers' (préférences associées à l'explorateur de fichiers Windows)
Messages postés
2
Date d'inscription
lundi 30 juillet 2012
Statut
Membre
Dernière intervention
21 septembre 2014
1
Mon expérience personnelle, avec MAMP serveur Apache pour Mac OS :
j'ai du mettre des valeurs spécifique à ce serveur :


database_port="3306"
database_password="root"

car le mot de passe root ne correspondait pas au mot de passe root que j'utilise (visiblement le root de MySql vit sa vie indépendamment de celui pour accéder à la console par exemple ! - j'ai mis du temps à la trouver celle-là)

Hope this helps !
Messages postés
379
Date d'inscription
lundi 17 septembre 2007
Statut
Membre
Dernière intervention
14 septembre 2013
30
SET PASSWORD FOR root@localhost=PASSWORD(' monmotdepasse ');

Et me voilà dare-dare éjectée de phpmyadmin Oo je comprend pas je peut plus y aller du tout. il me dit carrément qu'il ne trouve plus la page.
J'ai mis les nom et tout ça dans le fichier php.ini.
Y a vraiment plus moyen je ne peut plus accèder ni à ma database ni à phpMyAdmin c'est l'angoisse
Bonjour, j'aurai voulu savoir comment modifier ces qques lignes du fichier "config.inc.php", parce que pour ma part, impossible de l'ouvrir ><
j'ai changé le numero de port dans C:\Program Files (x86)\EasyPHP-5.3.5.0\conf_files\httpd.conf de 8888 en 8889 et tout marche bien mnt.
Messages postés
99
Date d'inscription
vendredi 1 octobre 2010
Statut
Membre
Dernière intervention
28 novembre 2014
5
Access denied 1045
j'ai suivi a la lettre le truc de jujuzilla et ca marche pas:phpmyadmin ne veut plus s'ouvrir! ,grrrr!
et pourtant en ligne de commande ou quand j'utilise sqlyog , ca marche!
svp de l'aide! et merci d'avance
très bien fait ..chapeau:)

GG jujuzilla!
attention je conseille de ne pas faire cette manipulation
car formatage pc oblige
a vous de voir
Messages postés
437
Date d'inscription
jeudi 27 décembre 2007
Statut
Membre
Dernière intervention
13 septembre 2013
78
Du gros n'importe quoi
D'accord avec KukrApOk59