Conditionnelle.. compliqué pour moi !

[Résolu/Fermé]
Signaler
-
 millenaire -
Bonjour,


Je travaille sur un document pour calculer les commissions des commerciaux. Il y a 2 types de prestations, et a ces deux prestations, des taux de commissions bien spécifiques

A la presta 1 : si 500: 5%, 1500 : 8% et si plus 10%
A la presta 2 : si 5000:5% 10 000:8% et si plus 10%

Le choix des presta se fait dans un menu déroulant.

J'ai réussi à faire le calcul de la presta 1 et de la presta 2, mais le problème réside alors que je veut faire un calcul avec les deux en même temps. Je n'arrive pas à rajouter le choix du calcul de la commission en fonction du calcul de la presta

Bref... je galère et voici ma formule

=SI(D11="Vente prestation web";SI(I11<=500;I11*5%;SI(I11<=1500;(I11-500)*8%+25;(I11-1500)*10%+120)));SI(D11="Vente site web";SI(I11<=5000;I11*5%;SI(I11<=10000;(I11-5000)*8%+250;(I11-10000)*10%+800)))

help me please et merci d'avance a tous

1 réponse

Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 091
Bonsoir
pas loin, à priori et sauf erreur...!
juste une parenthèse à enlever entre le groupe de SI N°1 et le N°2 et le rajouter à la fin.
voir les deux zones parenthèses en gras souligné ci dessous

=SI(D11="Vente prestation web";SI(I11<=500;I11*5%;SI(I11<=1500;(I11-500)*8%+25;(I11-1500)*10%+120));SI(D11="Vente site web";SI(I11<=5000;I11*5%;SI(I11<=10000;(I11-5000)*8%+250;(I11-10000)*10%+800))))



crdlmnt
Il est souvent plus facile de trouver la réponse que de comprendre la question
Merci !!! C'est bon ça fonctionne !